Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu 12.04 some days ago. All works well, except audio, that's completely missing.

I tried several solutions, in particular modification of the file

sudo gedit /etc/modprobe.d/alsa-base.conf

I try to add this line at the and of file, and change the last value several time

options snd-hda-intel index=0 model=3stack-dig

options snd-hda-intel index=0 model=generic

options snd-hda-intel index=0 model=6stack-dig

options snd-hda-intel index=0 model=auto

but nothing seems to work.

Output of lspci | grep -i audio is

00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]

Output of aplay -l is

**** List of PLAYBACK hardware devices ****
card 0: NVidia [HDA NVidia], device 0: HDA Generic [HDA Generic]
  Subdevice: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevice: 1/1
  Subdevice #0: subdevice #0

Output command sudo lshw appear both card, Nvidia and AMD

*-multimedia
          description: Audio device
          product: MCP61 High Definition Audio
          vendor: NVIDIA Corporation
          physical id: 5
          bus info: pci@0000:00:05.0
          version: a2
          width: 32 bits
          clock: 66MHz
          capabilities: pm msi ht bus_master cap_list
          configuration: driver=snd_hda_intel latency=0 maxlatency=5 mingnt=2
          resources: irq:23 memory:fbff8000-fbffbfff

 *-multimedia
             description: Audio device
             product: Caicos HDMI Audio [Radeon HD 6400 Series]
             vendor: Hynix Semiconductor (Hyundai Electronics)
             physical id: 0.1
             bus info: pci@0000:02:00.1
             version: 00
             width: 64 bits
             clock: 33MHz
             capabilities: pm pciexpress msi bus_master cap_list
             configuration: driver=snd_hda_intel latency=0
             resources: irq:43 memory:fbdfc000-fbdfffff

Thanks a lot.

share|improve this question
add comment

1 Answer

Why do you have both Nvidia and AMD appearing in the output of your command

lspci | grep -i audio

this is very suspect - do you really have two video cards from different manufacturers ?

Which of these appear in output of :

sudo lshw

ubuntu releases new versions every 6 months (12.04 was released month 4 of 2012) so 12.04 is 18 months old - I also experienced sound issues on earlier releases - ubuntu 13.10 seems fine. You can always burn onto a CD/DVD a download of 13.10 to see of booting into ubuntu 13.10 from the CD gives you sound. Alternatively, what do you get from simply going to your "System Settings" -> Sound -> Output to confirm you have selected valid settings. Under the "Output" tab it lists available output transports. Typically choose "Speakers built-in Audio" also hit the "Test Sound" button where you can hit the front left or right test buttons to send a test tone into either speaker.

share|improve this answer
    
I add output for command sudo lshw in question. I checked in "System Settings" -> Sound -> Output" but seems to be everything right, but test sound doesn't work. –  Ahriman Dec 31 '13 at 7:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.