Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have some difficulties with Ubuntu 13.10 (3.11.0-14-generic) and waking up from suspend state. Screen just goes blank, and there is some kind of prompt blink in upper right corner after I just need to restart my computer.

Specs:

  • DE: Gnome
  • Intel® Core™ i7-3770 CPU @ 3.40GHz
  • GeForce GTX 650/PCIe/SSE2
  • with: NVIDIA binary Xorg driver, nvidia-331 (open source)

  • 16 GB of RAM

  • (/ folder on SSD Drive, /home on HDD)

P.S.
Nvidia graphic driver works perfectly without any glitches.
Thanks for any help you can provide..

share|improve this question
    
It may have to do with the power manager. Try in the terminal using Code: sudo pm-suspend –  Ragavendra Mar 15 at 19:32
    
@MaciMint: If someone's answer was helpful to you, then please consider marking it as the accepted answer so others may more easily find it in the future. This is also a polite way to thank the person answering your question for helping you out. –  Danatela Mar 20 at 7:52

2 Answers 2

If the problem is that the system isn't turning your LCD backlight back on, then you can probably turn it back on manually..

Alt+F1 (go to a text virtual console) and then Alt+F7 (go back to the graphical X display)

The Alt+F1 should cause the backlight to come on, and then you can get back to your session with the Alt+F7

You might need to adjust the screen brightness with function keys on a laptop. This is if it is turning on the backlight but just at the lowest brightness.

There are multiple cases of this, not related to this card directly.

share|improve this answer
    
You need to test if you can ssh or connect to another service after the wake up command is issued. –  shadowbq Dec 30 '13 at 14:00
    
But if they see a prompt cursor in the top corner then it is not a backlight problem. –  Julian Stirling Dec 30 '13 at 14:39
    
He need to clarify the state of the machine, whether or not it recovered from suspend (ie. services running etc) to identify if it is a restore state, hardware(driver) or software problem. –  shadowbq Dec 31 '13 at 13:24

I had this very same problem and was wrestling with it for weeks. If you're still having problems try this: Disable Apport at Boot.

You need to manually edit a file to stop Apport running at boot (when you turn on your machine). Open the Terminal, and paste the following command with Ctrl+Shift+V, or type it in manually:

sudo nano /etc/default/apport

Change the line that says enabled=1 to enabled=0 to disable Apport. To re-enable, change it back.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.