Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new so please forgive me if i'm posting against the rules or something like that. I found some topics that are a bit related, but none with raid 10.

I'm going to switch from Windows server to Ubuntu 12.04 (finally !!!), but now I have a question:

I have a 128 GB SSD, that i want to use for the main OS, and I have four 1TB drives, that I want in a raid 10 configuration for all my data.

I already tried to install, but after the installation, i rebooted and then i get the raid configuration screen (that said that there aren't any raid drives), and then nothing but a black screen with a flickering cursor a the top left (as far as i know that means the isn't any OS detected).

So i booted in to recovery from the USB and from the [partition disk] menu, I see that my partition on the SSD is set to {not used}, but I'm sure I set it correctly before. The same is applying for the RAID volume.

What is the best thing I can do now ?

EDIT: @psusi, htnx for your replay. In the Intel raid configuration manager, I added all the drives to a raid 10 (0+1) configuration, after that I started the installation and Ubuntu auto detected the raid and added it to my partitioning list. Then U just mounted the raid partition to /home and made 2 new partitions on my SSD (boot and swap) and mounted the boot part. on /

here is the output:

~ # dmraid -s
**** Group superset isw_hjabdiead
--> Superset
name   : isw_hjabdiead_Data
size   : 3711742464
stride : 128 
type   : raid01
status : ok
subset : 2
devs   : 4
spares : 0

Ps: sorry can't get that code block working correctly :p

share|improve this question
    
It sounds like you are mixing up fakeraid and linux software raid. Had you set up the ssd to act as a cache using the bios fakeraid before? On the livecd, run sudo dmraid -s and edit the output into your question. –  psusi Dec 30 '13 at 15:03
    
So you have it working now? I would suggest avoiding the fakeraid stuff if you don't have to dual boot with Windows. It isn't as well supported as Linux software raid. I recently set up a 3 disk mdadm raid10 in the offset layout mode ( see the -p o2 switch to mdadm, and you'll also want an 8 MB or so chunk size ), and it has the read performance of raid0, so that would make it about twice as fast as using the fakeraid. –  psusi Dec 30 '13 at 18:44
    
no, it still isn't working, i tried re-installing a few times, with the "Ubuntu raid" and the Intel raid. But also, if I have a some sort of a dedicated raid chip on my motherboard, is isn't fake raid anymore ? or am I wrong ? my motherboard is a Supermicro X10-SLM-F –  remyseroos Dec 30 '13 at 18:56
    
It isn't a dedicated raid chip. It's the regular AHCI SATA controller built into the motherboard, and Intel has special bios extensions and Windows drivers to pretend that it's a hardware raid. I suggest you blow away the raid in the bios, make sure that dmraid -s doesn't see it any more, and install from there. –  psusi Dec 30 '13 at 19:17
    
okay, i figured it out. For some reason it was writing the EFI boot partition automatically to the raid array. So I just mounted an Gig partition on the ssd as EFI and it fixed everything. Thnx for you're help !! –  remyseroos Jan 3 at 23:11

1 Answer 1

up vote 0 down vote accepted

okay, i figured it out. For some reason it was writing the EFI boot partition automatically to the raid array. So I just mounted an Gig partition on the ssd as EFI and it fixed everything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.