Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm facing a problem while installing an ATI driver through ADDITIONAL DRIVER. I was trying to install the same in Ubuntu 13.04.

The config of my laptop is AMD Radeon HD 7640G/7670M Dual GPU (1 GB DDR3 dedicated)

I'm facing a tough time ahead my project due to this issue. I have tried almost everything available in net.

tried following the instruction given in unofficial AMD site ... but of no avail.

Now though I have UBUNTU 13.04 installed perfecly on my lappy.... The charge gets drained out in matter of just 15 minutes.

Also while booting ubuntu i get following error ERROR: CANNOT FIND A BACKLIGHT CONTROLLER before i enter my password...

Please Help..

share|improve this question

3 Answers 3

Do you have switchable graphics in your system?? If you do, then you could turn off your discrete graphics in order to prevent the battery getting drained out very quickly.

http://planetoss.com/articles/how-to-disable-the-discrete-amd-graphics-card-in-linux/

Go to the link above if you want to turn off the discrete graphics and use the integrated graphics available on your system.

share|improve this answer
    
Yes I have a switchable graphics,,,, The one mentioned in my query.....In that scenario the benefit of having switchable graphics is gone right??? –  Venu Dec 30 '13 at 15:50
    
Well if you do opt for turning of your discrete graphics, then yes the benefit would be gone and you'd only be able to work on the integrated graphics(intel chipset i suppose on your system) unless you switch discrete graphics on again which would cause you the same problem of battery drainage. You could try to download and install the amd drivers from their site which can help your cause, I had the same problem but the drivers didn't work properly for me. I suggest you should go ahead and install the amd drivers for linux and if that doesn't go well, you can switch off the discrete graphics. –  dazed_n_confused Dec 31 '13 at 9:34
    
the integrated graphics is again AMD and not intel. I have already tried installing the latest AMD graphics driver from their official site as mentioned in my question itself. –  Venu Dec 31 '13 at 15:51
up vote 1 down vote accepted

I switched over to Ubuntu 14.04 and installed the latest ATI graphics driver from AMD site and it is working fine now. Thanks to dazed_n_confused.

share|improve this answer

I have a similar problem!

To chage BACKLIGHT you can try:

chmod a+w /sys/class/backlight/acpi_video1/brightness

And repeatedly until change...

echo '4' > /sys/class/backlight/acpi_video1/brightness
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.