Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried with this and it works relatively well with few issues. Yesterday I tried to remove/reinstall the driver and after that I can't enable WiFi on my Lenovo ThinkPad E540.

uname -a

Linux metodiew 3.8.0-34-generic #49-Ubuntu SMP Tue Nov 12 18:00:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lspci -nn

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 10)
05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b723]

nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            r8168
  State:             connected
  Default:           yes
  HW Address:        28:D2:44:2E:C6:E6

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.101
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1

If I try to download drivers from GitHub, then make clean, make, sudo make isntall, sudo modprobe rtl8723be, I get an error:

ERROR: could not insert 'rtl8723be': Invalid argument

As @chili555 asked, here is what I get from: cat /var/log/syslog | grep -e rtl -e etwork | tail -n25

Dec 30 10:35:59 metodiew kernel: [ 1658.485960] rtl8723be: Unknown symbol ieee80211_find_sta (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.485984] rtl8723be: disagrees about version of symbol rtl_pci_disconnect
Dec 30 10:35:59 metodiew kernel: [ 1658.485987] rtl8723be: Unknown symbol rtl_pci_disconnect (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486001] rtl8723be: disagrees about version of symbol rtl_pci_suspend
Dec 30 10:35:59 metodiew kernel: [ 1658.486005] rtl8723be: Unknown symbol rtl_pci_suspend (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486021] rtl8723be: disagrees about version of symbol rtl_signal_scale_mapping
Dec 30 10:35:59 metodiew kernel: [ 1658.486025] rtl8723be: Unknown symbol rtl_signal_scale_mapping (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486055] rtl8723be: disagrees about version of symbol rtl_ps_enable_nic
Dec 30 10:35:59 metodiew kernel: [ 1658.486058] rtl8723be: Unknown symbol rtl_ps_enable_nic (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486072] rtl8723be: disagrees about version of symbol rtl_pci_resume
Dec 30 10:35:59 metodiew kernel: [ 1658.486075] rtl8723be: Unknown symbol rtl_pci_resume (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486106] rtl8723be: disagrees about version of symbol rtl_cam_add_one_entry
Dec 30 10:35:59 metodiew kernel: [ 1658.486110] rtl8723be: Unknown symbol rtl_cam_add_one_entry (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486137] rtl8723be: disagrees about version of symbol rtl_efuse_shadow_map_update
Dec 30 10:35:59 metodiew kernel: [ 1658.486141] rtl8723be: Unknown symbol rtl_efuse_shadow_map_update (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486154] rtl8723be: disagrees about version of symbol rtl_get_tcb_desc
Dec 30 10:35:59 metodiew kernel: [ 1658.486157] rtl8723be: Unknown symbol rtl_get_tcb_desc (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486182] rtl8723be: disagrees about version of symbol rtl_ps_disable_nic
Dec 30 10:35:59 metodiew kernel: [ 1658.486185] rtl8723be: Unknown symbol rtl_ps_disable_nic (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486204] rtl8723be: disagrees about version of symbol rtl_cam_get_free_entry
Dec 30 10:35:59 metodiew kernel: [ 1658.486208] rtl8723be: Unknown symbol rtl_cam_get_free_entry (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486220] rtl8723be: disagrees about version of symbol rtl_pci_probe
Dec 30 10:35:59 metodiew kernel: [ 1658.486224] rtl8723be: Unknown symbol rtl_pci_probe (err -22)
Dec 30 10:35:59 metodiew kernel: [ 1658.486236] rtl8723be: disagrees about version of symbol rtl_cam_delete_one_entry
Dec 30 10:35:59 metodiew kernel: [ 1658.486240] rtl8723be: Unknown symbol rtl_cam_delete_one_entry (err -22)

Now I have working Wired connection, but don't have option to enable/disable wireless connection.

Also as I said on other question from time to time I lost connection for some reason and after that I can't reconnect to the network. I have to reboot and after that I have WiFi.

I can confirm that chili555 method works for me. But I have strange problem - if I'm > connected and if I lost connection for some reasons, after that I can't connect to > any other(or same) WiFi. is anybody else having the same problem? Lenovo ThinkPad > E540.

Thanks in advance :)

UPDATE I select earlier kernel version:

Linux metodiew 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and now I have WiFi connection. Will update question if I still have problems with lost connection from time to time.

share|improve this question
    
I would love to see if there are any interesting warnings or errors in 'make.' Please run the process again and use 'make > make.txt.' That will create a text file make.txt. Find it in your user directory and paste it here and give us the link in your reply: paste.ubuntu.com –  chili555 Dec 30 '13 at 14:54
    
Of course. Here is the make.txt file from "make > make.txt" command: paste.ubuntu.com/6665388 It still gives me an error after 'sudo modprobe rtl8723be': ERROR: could not insert 'rtl8723be': Invalid argument I'm sure I made a mistake when I tried to reinstall old driver, but I'm not sure where. One more time - thanks foe everything! –  metodiew Dec 30 '13 at 22:36
    
Tell me about reinstalling the old driver. I'm suspicious that is where the conflict is. Your 'make' is perfect. –  chili555 Dec 30 '13 at 22:55
1  
Are you able to select an earlier kernel version at the GRUB menu? We might then reinstall the later: sudo apt-get install --reinstall linux-image-3.8.0-34-generic. The driver you deleted was for ethernet and shouldn't have any effect on wireless. –  chili555 Dec 30 '13 at 23:29
2  
If you solved your question please post what you did as a self-answer and mark it as such. It makes it easier for people to see that this is finalized and not spend time on it and for outside people to see that this is what they should follow. Thanks! –  RPi_Awesomeness Dec 31 '13 at 1:31

1 Answer 1

up vote 0 down vote accepted

Problem solved by asker:

Quote from the question:

I select earlier kernel version:

Linux metodiew 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and now I have WiFi connection. Will update question if I still have problems with lost connection from time to time.

This is to make it clear that the question has been solved, at least until the user self-answers. I will delete as soon as that happens.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.