Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I had to reinstall my ubuntu 12.04 due to some kernel installation issues. So i grabbed a new livecd and installed it. Went on to configure drivers and settings. I have bumblebee installed to handle the Nvidia 620M for 3D applications and the Intel HD4000 cpu integrated chip to do desktop environment and such.

THe issue being is after bumblebee was installed i didn’t see the login in screen anymore. But i heard the login screen sound so i typed in my password hit enter and voila it works. I want to fix this though what i have found so far is.

In virtual console starting lightdm returns with Failed to use bus name org.freeDesktop.DisplayManager do you have the appropriate permissions ?

I've looked around and cant find a solution similar problem i've seen like this was just unity to starting at all mine starts but only after logging in .

If I need to supply additional info please tell me so and I will do so.

Another discovery/insight. Turning on ALPM https://wiki.ubuntu.com/Kernel/PowerManagementALPM cause's the screen to be black on launch as well as the device isn’t properly called. Also has weird side effect on the wifi.

So i have it "FIXED" What i did is was a 12 hour wild goose chase around ubuntu ^^ In all seriousness I reinstalled to make sure it a a reproduce-able issue. After confirming it was I went into /etc/bumblebee/xorg.conf.nvidia and added my PCI BusID of my video card. This was to make bumblebee work. After I done this I had the same issue again. After some research I changed line 15 in /etc/bumblebee/bumblebee.conf TurnCardOffAtExit=false into TurnCardOffAtExit=true.

Now everything works as far as I can tell have to do some more testing. Another issue i have now even before bumblebee is that loging in takes ages(20+ sec). Would be nice if someone has an idea what that does.

EDIT: This does bring up the question that 620M doesn’t work out of the box (Meh it's linux nothing does) but if you follow http://askubuntu.com/a/36936/229978 There is no mention of it.

EDIT 2: still broken open for any suggestions

share|improve this question
    
If you solved your problem, please post a self-answer and then mark it as answer as soon as possible. Thanks! –  RPi Awesomeness Dec 31 '13 at 0:17

1 Answer 1

From what I understand, [and correct me if I'm wrong] your problem is stated in the title and is Unity-related. Can you try:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:unity-team/staging
sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity

You can also try going to Synaptic Package Manager and "Mark for Reinstallation" only after you've done the above.

If I'm wrong, though, please clarify what exactly you're trying to fix/do.

share|improve this answer
    
Will try right now. Just got a new lead getting out of hibernation it returns this pci device is not a vga device. I'll let you know where I end up. –  Tim Timmermans Dec 30 '13 at 7:37
    
This is what i found when doing $ sudo ppa-purge ppa:unity-team/staging. Updating packages lists PPA to be removed: unity-team staging Warning: Could not find package list for PPA: unity-team staging. Thank you so far for you help. –  Tim Timmermans Dec 30 '13 at 7:53
    
Hmm, have you done the general update via SU or terminal? Are you still having this issue? –  Mike Kuplevatsky Dec 30 '13 at 14:53
    
I did apt-get update multiple times and tan the update manager multiple times. still having it even after my latest post. I don't know what to do I think I've tried everything I know. I know12.04 LTS has an update that supposedly fixes this. don't know if I have it. –  Tim Timmermans Dec 30 '13 at 19:12
    
Sorry for such late delays. By any chance, do you have NVIDIA card? –  Mike Kuplevatsky Dec 30 '13 at 23:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.