Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm facing issue with PPPOE connection,

Error logs :

Dec 29 15:50:20 rahul-home pppd[4141]: PPP session is 1769
Dec 29 15:50:20 rahul-home pppd[4141]: Connected to 00:27:0e:14:d1:04 via interface eth0
Dec 29 15:50:20 rahul-home pppd[4141]: Using interface ppp0
Dec 29 15:50:20 rahul-home pppd[4141]: Connect: ppp0 <--> eth0
Dec 29 15:50:20 rahul-home NetworkManager[1131]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring...
Dec 29 15:50:20 rahul-home NetworkManager[1131]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Dec 29 15:50:20 rahul-home NetworkManager[1131]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Dec 29 15:50:20 rahul-home pppd[4141]: CHAP authentication failed: bad username or password
Dec 29 15:50:20 rahul-home pppd[4141]: CHAP authentication failed
Dec 29 15:50:20 rahul-home pppd[4141]: Connection terminated.
Dec 29 15:50:20 rahul-home NetworkManager[1131]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Dec 29 15:50:20 rahul-home avahi-daemon[859]: Withdrawing workstation service for ppp0.
Dec 29 15:50:22 rahul-home pppd[4141]: Terminating on signal 15
Dec 29 15:50:22 rahul-home pppd[4141]: Exit.

Success Log

Dec 29 15:50:24 rahul-home pppd[4189]: PPP session is 22450
Dec 29 15:50:24 rahul-home pppd[4189]: Connected to 00:07:e9:a5:a8:85 via interface eth0
Dec 29 15:50:24 rahul-home pppd[4189]: Using interface ppp0
Dec 29 15:50:24 rahul-home pppd[4189]: Connect: ppp0 <--> eth0
Dec 29 15:50:24 rahul-home NetworkManager[1131]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring...
Dec 29 15:50:24 rahul-home NetworkManager[1131]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Dec 29 15:50:24 rahul-home NetworkManager[1131]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Dec 29 15:50:24 rahul-home pppd[4189]: CHAP authentication succeeded: Welcome.
Dec 29 15:50:24 rahul-home pppd[4189]: CHAP authentication succeeded
Dec 29 15:50:24 rahul-home pppd[4189]: peer from calling number 00:07:E9:A5:A8:85 authorized
Dec 29 15:50:24 rahul-home pppd[4189]: local  IP address xx.xx.xx.xx
Dec 29 15:50:24 rahul-home pppd[4189]: remote IP address 172.31.29.1
Dec 29 15:50:24 rahul-home pppd[4189]: primary   DNS address xx.xx.xx.xx
Dec 29 15:50:24 rahul-home pppd[4189]: secondary DNS address xx.xx.xx.xx

My Observation

I have tested with n number of attempt, but I've notice that dialer get connected when it using peer calling number 00:07:E9:A5:A8:85, but I'm unable to fix this. with help of man pppd, I've tried following option in /etc/ppp/options

allow-number 00:07:E9:A5:A8:85  # Tested showing not authorized
remotenumber 00:07:E9:A5:A8:85  # Tested but not working

Temporary Solution

#!/bin/bash

# Retry pppoe until get connected

rndc stop

interval=2
n=0
pppstats && { echo "Internet is working"; exit 1; }
until nc -vzw1 titanic 80 
do
    poff -a ||
    pon dsl-provider
    sleep $interval 
    ((n++))
done

echo "Dialer Connected after total retry: $n"
plog
/etc/init.d/bind9 start

Specs

Distributor ID: Ubuntu
Description:    Ubuntu 13.10
Release:    13.10
Codename:   saucy

pppd version 2.4.5

Question

How do I set fix calling number in pppoe ?

share|improve this question

1 Answer 1

After enabling debug logs, I've found the solution

The issue was

There are two groups in our local ISP, we can see using :

root@rahul-home:~# pppoe-discovery 
AC-Ethernet-Address: 00:07:e9:a5:a8:85
Access-Concentrator: spidernet
       Service-Name: spidernet
--------------------------------------------------
AC-Ethernet-Address: 00:27:0e:14:d1:04
Access-Concentrator: Fivenet
       Service-Name: 5network
--------------------------------------------------

the calling number which I was asking it is actually ACNAME 00:07:e9:a5:a8:85 i.e spider.

Now the question is How do I set fix ACNAME and Service name ?

I've checked man pages but haven't found related to the same, but after Googling I've found the the solution, which is Bug reported in 2010, but still not updated man pages.

and the solution

we need to go to the /etc/ppp/peers/dsl-provider configuration file. There is a line: plugin rp-pppoe.so ethX

Where we can specify multiple options such as:

plugin rp-pppoe.so rp_pppoe_service SERVICE_NAME rp_pppoe_ac ACCESS_CONCENTRATOR ethX

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.