Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just recently installed Ubuntu 13.10 and decided to install the necessary Nvidia driver:

sudo apt-get install nvidia-current

Then I reboot and find to have the black screen. I went into the terminal with Control-Alt-F1 and executed the following and rebooted:

sudo apt-get remove nvidia-current

But I still get the black screen. How can i fix this?

share|improve this question
    
try sudo apt-get purge nvidia-current –  Avinash Raj Dec 29 '13 at 9:42
    
Ok, I tried doing that and I still get the black screen. When I went and logged into the terminal, I also tried startx but that didn't work too –  Tihomir Dec 29 '13 at 9:49
add comment

3 Answers 3

up vote 1 down vote accepted

Try these commands on virtual console(ctrl+alt+F1),

sudo rm /etc/X11/xorg.conf
sudo apt-get purge nvidia*
sudo service lightdm restart
share|improve this answer
    
Apparently there is no such file or directory as /etc/X11/xorg.conf –  Tihomir Dec 29 '13 at 10:03
    
But I tried the second command but it is still a black screen and startx doesn't work either –  Tihomir Dec 29 '13 at 10:03
    
try sudo apt-get purge nvidia* in virtual console. –  Avinash Raj Dec 29 '13 at 10:07
    
Now that worked! Thanks a lot! –  Tihomir Dec 29 '13 at 10:13
    
@Tihomir mark this answer as accepted by clicking the tick –  Qwertie ϟ Dec 29 '13 at 10:14
add comment

If you installed the Nvidia Proprietary drivers and you get a black screen, you probably need to set nomodeset. So try to install the driver again and then do the following to get around the black screen.

To do this you need to:

  1. Hold down Shift while booting, until you get to the Grub boot menu.
  2. Select your boot option and press e to edit it.
  3. Edit the line that has "quite splash" in it to "quite splash nomodeset"
  4. Try booting that by pressing F10.
  5. If it works, make it permenant by editing /etc/default/grub to display the same in that particular line. Remember to do a sudo update-grub afterwards.
share|improve this answer
    
I tried the method that you have stated and only to find out that it doesn't work for me. I am going to have to find another way to install the Nvidia Drivers –  Tihomir Dec 29 '13 at 12:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.