Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed lappstack, and used the Ubuntu Software Center to install pgAdmin3. I am getting the error

Warning : The server you are connecting to is not a valid version that is supported by by this release of pgAdmin III. pgAdmin III may not function as expected. Supported server versions are 8.2 to 9.1

Can someone please explain how am I supposed to update my pgAdmin? I tried the update app, and it downloaded some GUI update.

How am I supposed to update it to the latest version? I am new to linux, and I'd appreciate simple solutions. Thanks.

share|improve this question
1  
Try to find out if the error message in your question refers to the PostgreSQL server from LAPP stack, which is currently at version 9.1 in the Ubuntu Software Center for Ubuntu 12.04, 12.10 and 13.04 and version 9.3 for Ubuntu 13.10. –  karel Dec 29 '13 at 4:53
    
What is your Ubuntu version? –  Dumindu Mahawela Dec 29 '13 at 5:05
    
My version : Ubuntu 12.04.3 LTS I think its from the pgAdmin3 that needs to be updated. How can I update my pgAdmin3? Is there a way to do it from the terminal? –  user229710 Dec 29 '13 at 5:40
    
Can do it with sudo apt-get --only-upgrade install pgadmin3 –  Dumindu Mahawela Dec 30 '13 at 5:51
    
But this not seems to solve it. Can you post the output of apt-cache policy pgadmin3 and apt-cache madison pgadmin3 in your question? –  Dumindu Mahawela Dec 30 '13 at 6:02
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.