Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Vuze gives an error that "0 users" are connected, and a firewall error. I don't think it's the network, because the same network was working fine just a few hours ago.

Vuze was working perfectly up to earlier today. I had been running 12.04 LTS, but did a clean install and put on 13.10 desktop. Now, vuze just doesn't connect.

The specific diagnostic error:

Testing port 24488 ... NAT Error - Connect attempt to 96.55.205.166:24488 (your computer) timed out after 20 seconds. This means your port is probably closed.

Although, just a litte while ago that worked fine, even after the clean install, but was still giving "0 users" -- so I don't put much into that diagnostic.

While it's a wireless connection to a router, it was working fine earlier today. I highly, highly, doubt the router is the problem. I do not have physical access to the router.

thufir@dur:~$ 
thufir@dur:~$ java -version
java version "1.7.0_25"
OpenJDK Runtime Environment (IcedTea 2.3.12) (7u25-2.3.12-4ubuntu3)
OpenJDK Client VM (build 23.7-b01, mixed mode, sharing)
thufir@dur:~$ 
thufir@dur:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:13:20:ac:13:b0  
          inet addr:192.168.0.19  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::213:20ff:feac:13b0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:66688 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41338 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:33718783 (33.7 MB)  TX bytes:3971188 (3.9 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1271 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1271 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:122835 (122.8 KB)  TX bytes:122835 (122.8 KB)

thufir@dur:~$ 

Switching the port to 24489 gives:

Testing port 24489 ... OK !

but still "0 users", so that's no progress at all.

What does "0 users" really mean, and how do I get connected again? Proceeding on the assumption that the network isn't the problem (it was working earlier today fine), that the break is correlated exactly with the clean install, and that I don't have physical access to the router.

What diagnostics can I run on Vuze itself?

Here is the startup from console:

thufir@dur:~$ 
thufir@dur:~$ vuze
[warning] /usr/bin/vuze: No java runtime was found
[warning] /usr/bin/vuze: No JAVA_CMD set for run_java, falling back to JAVA_CMD = java
file:/usr/lib/jni/ ; file:/usr/lib/java/ ; file:/usr/share/java/Azureus2.jar ; file:/usr/share/java/log4j-1.2-1.2.17.jar ; file:/usr/share/java/commons-cli-1.2.jar ; file:/usr/lib/java/swt-gtk-3.8.2.jar ; file:/home/thufir/
changeLocale: *Default Language* != English (Canada). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (Canada)' (en_CA), using 'English (default)'
UIFunctions/ImageLoad took 35ms
new shell took 352ms
new shell setup took 78ms
share|improve this question
    
see also: forum.vuze.com/thread.jspa?threadID=120185 –  Thufir Dec 29 '13 at 7:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.