Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS S400C running Ubuntu 13.10. After shutting down overnight and restarting this morning, I noticed there was no visible mouse cursor and trackpad events were not firing - no left or right click, no two-finger scrolling. The touchscreen is still working fine, however the pointer sprite isn't displayed. If I log out, the touchpad mouse works fine and is visible on the log in screen. If I move the cursor around with the touchpad while it is logging in, it freezes at a point between the log in screen and my account opening, while the screen is still black. Using the touchscreen after that point causes the cursor to become invisible again.

sudo modprobe -r psmouse && sudo modprobe psmouse

has no effect.

gsettings set org.gnome.settings-daemon.plugins.cursor active false

renders the cursor visible, but the touchpad is still disabled. The cursor remains visible for touchscreen events.

gsettings set org.gnome.settings-daemon.plugins.cursor active true

returns the situation to as originally described.

In short: help!

EDIT 1: Output of synclient -l:

Parameter settings:
    LeftEdge                = 129
    RightEdge               = 3120
    TopEdge                 = 120
    BottomEdge              = 2103
    FingerLow               = 1
    FingerHigh              = 1
    MaxTapTime              = 180
    MaxTapMove              = 173
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    EmulateMidButtonTime    = 0
    EmulateTwoFingerMinZ    = 282
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 78
    HorizScrollDelta        = 78
    VertEdgeScroll          = 0
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 1
    HorizTwoFingerScroll    = 1
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.050813
    TouchpadOff             = 2
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 3
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 19
    VertHysteresis          = 19
    ClickPad                = 1
    RightButtonAreaLeft     = 1624
    RightButtonAreaRight    = 0
    RightButtonAreaTop      = 1822
    RightButtonAreaBottom   = 0
    MiddleButtonAreaLeft    = 0
    MiddleButtonAreaRight   = 0
    MiddleButtonAreaTop     = 0
    MiddleButtonAreaBottom  = 0
share|improve this question
    
please provide output of > synclient -l –  sgx1 Dec 29 '13 at 2:18
    
sgx1 : I've updated the question with that at "EDIT 1" –  hidenori Dec 29 '13 at 2:35
    
obviously, your touchpad is not enabled. Option "TouchpadOff" 0 Touchpad is enabled 1 Touchpad is switched off 2 Only tapping and scrolling is switched off –  sgx1 Dec 29 '13 at 2:50
    
in your case TouchpadOff=2, so tapping and scrolling is switched off. –  sgx1 Dec 29 '13 at 2:52
    
go to system settings->mouse&touchpad and test with the touchpad options. –  sgx1 Dec 29 '13 at 2:54

1 Answer 1

up vote 0 down vote accepted

obviously, your touchpad is not enabled. see > man synaptics :

Option "TouchpadOff"
0 Touchpad is enabled
1 Touchpad is switched off
2 Only tapping and scrolling is switched off

in your case TouchpadOff=2, so tapping and scrolling is switched off.

go to system settings->mouse&touchpad and enable touchpad.

NOTE: synclient is is always your friend when debugging touchpad. all its options are documented by 'man synaptics'. you can change touchpad options directly by synclient, but the settings can not persist after the user session. this is when gnome-settings-daemon comes into play. gnome-settings-daemon re-applies the system settings every time a new user session starts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.