Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am in the process of trying to get my mono website to run on Apache. I've gone through various tutorials on the installation and testing, and while I can get mono to run through xsp from the development server, Apache simply won't work.

I receive, mod_mono and xsp have different versions. Expected '9', got 8

I've tried installing mono probably 4 or 5 times through different tutorials, so I don't know where I've gone wrong. There doesn't seem to be a whole lot of help for this issue anywhere -- as I've searched pretty deeply.

When I run the command sudo apt-get install mono-xsp2, I receive mono-xsp2 is already the newest version. The same goes for mono-server-2. I receive mono-apache2-server is already the newest version.

The complete error is

System.InvalidOperationException: mod_mono and xsp have different versions. Expected '9', got 8 at Mono.WebServer.ModMonoRequest.GetInitialData () [0x00000] in :0 at Mono.WebServer.ModMonoRequest..ctor (System.Net.Sockets.Socket client) [0x00000] in :0 at Mono.WebServer.RequestReader..ctor (System.Net.Sockets.Socket client) [0x00000] in :0 at Mono.WebServer.ModMonoWorker.InnerRun (System.Object state) [0x00000] in :0 at Mono.WebServer.ModMonoWorker.Run (System.Object state) [0x00000] in :0 [Tue May 03 09:51:35 2011] [error] (104)Connection reset by peer: read_data failed [Tue May 03 09:51:35 2011] [error] Command stream corrupted, last command was -1

share|improve this question

closed as too localized by fossfreedom Feb 18 '12 at 21:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned and unanswered. This will be closed. If this question is still valid, please add more detail and flag for it to be reopened. –  fossfreedom Feb 18 '12 at 21:59

Browse other questions tagged or ask your own question.