Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to understand the differences between EFI (UEFI?) partition systems and the old BIOS systems for the last week, but I don't seem to get anywhere.

Problem: Getting my computer to boot normally. I would be happy to do a complete reinstall, but I need to understand what has to be done to get this EFI-stuff to work, and none of the guides I've found bring any luck.

Background info: - boot-repair boot-info summary: http://paste.ubuntu.com/6651440/

Prehistory:

  1. I had only Win7 installed.
  2. I installed Kubuntu next to Win7 without any particular problems, but found that KDE was a bit heavy on my machinery and decided to try Lubuntu.
  3. Installing Lububuntu, I was asked whether I wanted to overwrite the previous Kubuntu installation, I (in a moment of low comprehension) accepted that, not understanding that this would probably also wipe my Win7 partition, the recovery partiotion and all else - which is what I assumed happened.
  4. Then suddenly, the installation program produced an error message stating that there was an unencrypted swap drive active, and aborted. And after this, I have been struggling for days to be able to boot my computer without my LiveUSB (the booting of which also proved quite frustrating after this.
  5. I have tried loads of solutions found on Ubuntuforums and AskUbuntu, trying to install Lubuntu in EFI-mode (the existence of which I was not aware before I started this).

This is where I stand now:

Using the Lubuntu installation programme, I have installed Lubuntu (no dual boot) with a 500 mb EFI (fat32) partition (sda1), a 460 gb Lubuntu partition (sda2) and a 5 gb swap partition (sda3).

The system, however, would not boot on anything but the LiveUSB, so I tried boot-repair from the LiveUSB, which clearly identified the EFI system at startup, hoping it would simply reinstall Grub2 and all would be fine. No luck, however. For some reason, when I start up my computer, all I get is a request to "Reboot or Select proper Boot device".

What I did after this (and I'm sorry that I have lost track of which forum posts I got my tentative fixes from, so I can't refer) was to format sda1 (the EFI partition) to "cleared", using Gparted, and providing it with the flag "bios_grub". Then I ran boot-repair again, ignored what warnings popped up and let boot-repair reinstall Grub again. I rebooted and got the same old request to "Reboot or Select proper Boot device". However, when I push Esc on startup and actively choose to boot from the hard drive, this works. So now I can cumbersomly boot my computer through what I have understood is commonly referred to as "legacy" in these forums, although it seems my computer expects EFI boot (I might be completely off here, I really don't understand what I'm doing here).

This is definitely sub-optimal, so I wanted to try installing the system again, with a functional Grub. Assuming that maybe the Lubuntu installation messed up, I therefore tried making a Ubuntu LiveUSB. I booted the computer, and - pushing Esc, getting up the BIOS boot menu - I tried both the "normal" and the EFI-option for booting the USB, but none of them worked.

In the situation I'm in, I can easily wipe anything of my hard drive, I just want to be able to install a functioning boot system, and I don't understand what I am doing wrong, since what I have found of guides to install EFI systems seem so simple. All I'm supposed to need is this EFI partition, but my computer doesn't seem to recognise it.

PS: Boot-repair says "Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/grubx64.efi file!" How do I do that? Is this what I've done wrong?

Also, for reference, here is a ("solved") thread I posted on Ubuntuforums for my first problem of the dual boot that got messed up. I don't think any of this is relevant here, however: http://ubuntuforums.org/showthread.php?t=2195105

I am very grateful for any help you can provide! I'm at a loss and a bit demoralised by being forced to learn about (U)EFI during the last days, not understanding what to do.. There is probably to much information here already, but if anything else should be here for you to understand the problem, I'm happy to provide!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.