Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am using 64-bit Ubuntu 13.10 and I have Eclipse (exactly adt-bundle-linux-x86_64-20131030) with SDK, I am trying to learn how to make my own Android application but Eclipse is closing automatically and randomly with no errors or warning. I run it in terminal and then it shows me some issues.

This is the terminal output:

 A fatal error has been detected by the Java Runtime Environment:

 SIGSEGV (0xb) at pc=0x00007fbcae8f2c91, pid=5707, tid=140449979574016

 JRE version: 7.0_25-b30
 Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
 Problematic frame:
 C  [libsoup-2.4.so.1+0x6ac91]  soup_session_feature_detach+0x11

 Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

 An error report file with more information is saved as:
/home/anarki/Dokumenty/adt-bundle-linux-x86_64-20131030/eclipse/hs_err_pid5707.log

 If you would like to submit a bug report, please include
 instructions on how to reproduce the bug and visit:
   https://bugs.launchpad.net/ubuntu/+source/openjdk-7/
 The crash happened outside the Java Virtual Machine in native code.
 See problematic frame for where to report the bug.
share|improve this question

2 Answers 2

I believe this answer on stackoverflow will solve your problem. http://stackoverflow.com/a/20204258

Technically it is just a workaround, but it solved my problem.

the link content:

Check bug report https://bugs.eclipse.org/bugs/show_bug.cgi?id=404776 . I suggest you > to upgrade to the newest Eclipse 4.3 (Kepler).

Alternativelly you can try workaround suggested in comment #6:

For a workaround add the following to the end of your eclipse.ini

-Dorg.eclipse.swt.browser.DefaultType=mozilla

~ answered Nov 25 '13 at 22:00 [Pavel Horal]

share|improve this answer

I add following line to eclipse.ini

-Dorg.eclipse.swt.browser.DefaultType=mozilla

and

org.eclipse.swt.browser.DefaultType=mozilla

to config.ini , and my probelm solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.