Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using openvpn to connect to the network in my company.

From time to time, the network manager daemon gets stupid, and I have to kill it. When I do it, it connect the network, but not the openvpn, and the icon to connect to the open vpn disappears.

Is there a way to restart this daemon nicely?

EDIT: To kill the daemon, I do it like this : killall -9 kded4

share|improve this question
add comment

2 Answers

I had also faced the same problem. Whenever I tried to disconnect from the VPN (in my case it was PPTP) server, KDE Network Manager takes 100% CPU. I used to kill KDE4 from "System Monitor". But even getting there takes a lot of time because the whole system behaves slow to any activity.

Found quite a few bugs reported for this issue. The one I mention here will give us more details about the issue : https://bugs.kde.org/show_bug.cgi?id=268038

To solve the issue, about a few days back I had to check on the "pre-release updates" from software souces-->origin under Kpackagekit. Several updates were installed and the issue got fixed.

From the above ticket it seems the updates are already there in Kubuntu updates and you probably don't need to install those pre-release updates. Just check whether there is any update available for you or not.

In case there is no available update from the regular channel, then you might want to try the above process as tried by me. But before proceeding please note that as per my knowledge, pre-release updates might bring in other issues. So please be sure before installing the pre-release updates.

share|improve this answer
    
Cool. So the package is fixed in pre-release. Can't wait, because I haven't found a work around other then killing kde4 process –  BЈовић Jun 8 '11 at 7:00
add comment
up vote 0 down vote accepted

bug 333944 describes the problem I am experiencing, and the solution is to start kded4 in the terminal

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.