Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the 11.04 64bit version and now i can't install Draftsight (32bit with force architecture option) because there is an error with the library libexpat1.. anyone know how solve?

andrea@andrea-HP-Pavilion-dv5-Notebook-PC:~$ sudo dpkg --force-architecture -i DraftSight.deb 
[sudo] password for andrea: 
dpkg: warning: the following problems are ignored via the --force option:
 the architecture of the package (i386) does not match system (amd64)
dpkg: problems with pre-dependencies DraftSight.deb containing dassault-systemes-draftsight:i386:
 dassault-systemes-draftsight:i386 depends on libexpat1 (>= 2.0.1-4)
dpkg: errore processing DraftSight.deb (--install):
 dependency problem - dassault-systemes-draftsight:i386 not installed
There were errors in processing:
 DraftSight.deb
andrea@andrea-HP-Pavilion-dv5-Notebook-PC:~$ 

Editor's note: the error messages have been translated and don't match the real ones exactly.

share|improve this question
add comment

17 Answers

After you install all dependencies mentioned above (that is libdirectfb-extra, libxcb-render-util0, libaudio2) you should install Draftsight using the following command:

sudo dpkg -i --force-architecture,depends ./DraftSight.deb

Obviously you should run this command while inside the folder where you have saved Draftsight.deb.

Worked on Ubuntu 11.04 x64

share|improve this answer
add comment

From: OMG Ubuntu

Free AutoCAD clone ‘DraftSight’ hits Linux Beta

Download a pre-packaged .deb file for Ubuntu 9.10+ at the following link: download (66.8MB)

64bit Ubuntu users note: The DraftSight beta .deb provided is 32bit. To get DraftSight to run in Ubuntu 64bit will need to install the following missing library:

 sudo apt-get install libdirectfb-extra libxcb-render-util0

After this, install the .deb via a Terminal using the ‘force architecture’ command. Assuming you downloaded it to your Downloads folder:

sudo dpkg --force-architecture -i ~/Downloads/draftSight.deb

You probably did not install the missing library.

share|improve this answer
    
I had to install libcamberra0 to get it to run on 13.10. –  Javier Rivera Oct 10 '13 at 8:45
add comment

On 64bit Kubuntu 12.04 there is a libgtk-x11 error.

/var/lib/dpkg/tmp.ci/ShowLicence: error while loading shared libraries: libgtk-x11-2.0.so.0: c

Solve with this:

sudo apt-get install libgtk2.0-0:i386
share|improve this answer
1  
thanks! works in Xubuntu 12.04 as well! –  smiddy84 Jan 15 at 17:10
add comment

Transcribe what I found in ubuntuforums (resolved by player107):

The procedure is :

"unpack the draftsight file in some directory (ex : DS)

then copy the contents of DS/opt/ and DS/var/ to /opt and /var/opt

then go to DS/DEBIAN

then sudo ./preinst

then sudo ./postinst

then a menu should have been created in the graphical ubuntu menu : you can launch it"

He mentions he has a problem with the screen, but no me. To avoid this do the following:

sudo apt-get install libdirectfb-extra

sudo apt-get install libxcb-render-util0

I hope you serve like me.

share|improve this answer
    
This solution is perfect!! –  Andrea May 13 '11 at 7:16
add comment

Installing on Ubuntu 11.10 64 bit can by skipping the dpkg-installer:

http://linuxaideddesign.blogspot.com/2011/10/draftsight-and-ubuntu-1110-64bit.html

share|improve this answer
add comment

I found that it is possibly to run this software by running it as a root (sudo) but still not functional trough normal launcher. Ubuntu 11.04 start command is:

sudo /opt/dassault-systemes/draftsight/bin/DraftSight

or you don't have even to do that

just extract .deb file and run it as a root and it will work.

There is only a problem to run it as normal user

share|improve this answer
add comment

I have succeeded in to install draftSight in Ubuntu 12.04 (beta2) 64 bit. I just have installed the required libraries and then extracted the .deb file content.

I copied the extracted folder to /usr/local/ and then just change the owner:

sudo chown -R user:group draftSight/

After that i just have created a launcher in the desktop..

Cheers....

share|improve this answer
add comment

I have tried forcing the architecture to install DraftSight, even after installing the packages mentioned in the previous posts, but I always get this error:

dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
dpkg: regarding DraftSight.deb containing dassault-systemes-draftsight:i386, pre-dependency problem:
 dassault-systemes-draftsight:i386 pre-depends on libexpat1 (>= 2.0.1-4)
  libexpat1:i386 is unpacked, but has never been configured.
dpkg: error processing DraftSight.deb (--install):
 pre-dependency problem - not installing dassault-systemes-draftsight:i386
Errors were encountered while processing:
 DraftSight.deb

I have tried installing this libexpat library through getlibs but nothing seems to let DraftSight install correctly.

Consequently, I tried the method copying the files manually (suggested by Juan José Alca Machaca), and DraftSight appears in the menu and I can run it, but it crashes when I do common operations, or run commands like DimensionStyle

share|improve this answer
add comment

Above solutions does not worked in fresh install of natty narwhale 11.04 64 bit.

System crashed after attempts: dpkg with force & make deb file for all architectures & trying alien rpm to deb & (re)installation and configuration libraries for i386 (supposed it destroyed system). I rescue system with reinstallation and configuration libraries for amd64 & update and upgrade system. Ubuntu 11.04 Natty and DraftSight works.

You can try install libc6 for i386 (simultaneously to already installed libc6 for amd64) from synaptic. I guess it helps in my case.

share|improve this answer
add comment

Ubuntu 11.10 64 bit there is still dependency problem:

dassault-systemes-draftsight:i386 wymaga wstępnie libdirectfb-extra (>= 1.2.7-2)

BUT it works if You extract DraftSight.deb, then run ./DraftSight/opt/dassault-systemes/draftsight/bin/DraftSight

share|improve this answer
add comment

Don't forget to right click 'DraftSight.deb' then choose 'Properties'. Select the 'Permissions' tab, and click ' Allow Executing File as Program'. Then run:

sudo dpkg -i --force-architecture,depends ./DraftSight.deb
share|improve this answer
add comment

I finally got it to work under Ubuntu 11.04 64 bit.

First follow detailed instruction (one of above since pretty much any method will work). Don't forget to put all dependencies

Believe me or not after I installed it I had to delete configuration files in home directory which are starting with "." or move them to some folder if you have wine app or something like that.

For people which doesn't like this idea, to delete configuration files, try to create another user account and run it from there.

After that I found out that enabled *buttons have icons application will crach when i try for example to click on Open.*

and that's it for now. When I get more knowlegde i will postenter image description here

share|improve this answer
add comment

In ubuntu 12.04, consider modifying the control file of the deb package to remove dependence problem. The systems seems to keep track of the problem and de-installing the application, next time synaptic/dpkg is recalled.

more info at http://linuxaideddesign.blogspot.it/2012/03/draftsight-and-ubuntu-1204-lts-64bit.html

share|improve this answer
add comment

"I found that it is possibly to run this software by running it as a root (sudo) but still not functional trough normal launcher. Ubuntu 11.04 start command is:"

Jorge Castro: I faced the same problem after installing DraftSight. I solved it by running DEBIAN/preinst script 'as normal user', it then asks for administrator password, then the licence agreement gui shows up(accept it). Keep doing it until it says "access control disabled, clients can connect from any host" in the terminal, run postinst script after that.

You may want to delete any '.draftsight' dir in your home directory PRIOR to running the scripts in DEBIAN folder.

share|improve this answer
    
You may want to delete any '.draftsight' dir in your home directory PRIOR to running the scripts in DEBIAN folder. –  kapz Dec 20 '11 at 19:20
add comment

I had the same problem but solved finally. Here is the solution:

  1. Install the two missing dependencies:

    sudo apt-get install libxcb-render-util0
    sudo apt-get install libdirectfb-extra
    
  2. Move your DraftSight.deb file to your home folder /home/yourusernamehere.

  3. Then you have to force install the DraftSight package:

    sudo dpkg -i --force-architecture DraftSight.deb
    

It is working for me.

share|improve this answer
add comment

Solved!

Source: http://steamcommunity.com/app/221410/discussions/0/846940248727134912/

Solution:

sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install ia32-libs

You'll have to download files while updating. about 200MB, depends on your situation.

I'm using ubuntu 12.10.

share|improve this answer
add comment

Solved for me!

I followed the below steps and it worked for me (this is after I had downloaded the dependencies as described above).

http://linuxaideddesign.blogspot.hu/2012/03/draftsight-and-ubuntu-1204-lts-64bit.html?showComment=1388073087803#c3900507486161931220

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  guntbert Dec 26 '13 at 17:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.