Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep getting 'no route to host' when I try ssh phablet@ip. I've already read the release notes on how to set it up but it doesn't work.

  • I already have openssh-server and ssh packages on my laptop and phone (nexus 4). SSH on phone is outdated though but can't update it (can't find the package, 404 error).

  • My wlan and lan networks don't have different subnet masks but to make sure I connected my laptop via wifi and got the same error. Weird thing is my phone can ssh to my laptop (by connect I mean: Permission denied (publickey)) but doesn't work the other way around. I'm sure the ip is right because I've assigned a static ip to 'ubuntu-phablet'

  • I have already tried this even though I didn't have that problem.

EDIT: i've changed from trusty r79 to trusty-proposed r101. still have the same issue. although i was able to update the ssh package. this time i get 'Connection refused'. i still can ssh from my phone to my laptop but not the other way around.

Fixed. ssh service wasn't started.

      phablet@ubuntu-phablet:~$ sudo ifconfig
      Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:347 errors:0 dropped:0 overruns:0 frame:0
      TX packets:347 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:26554 (26.5 KB)  TX bytes:26554 (26.5 KB)

      wlan0     Link encap:Ethernet  HWaddr 10:68:3f:7f:26:60  
      inet addr:192.168.1.110  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::1268:3fff:fe7f:2660/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:466 errors:0 dropped:0 overruns:0 frame:0
      TX packets:428 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:100 
      RX bytes:41581 (41.5 KB)  TX bytes:37169 (37.1 KB)
share|improve this question
1  
Answered in: askubuntu.com/questions/348714/… SSH is (by default) disabled. –  david6 Dec 28 '13 at 23:26
    
i've read that before . doesn't work. + his problem was not being able to install it. –  MHB Dec 29 '13 at 15:19
    
Did you try the answer though? –  Seth Dec 29 '13 at 16:38
    
yes. i think this is probably a network problem (i've searched for that too, doesn't work) or maybe something wrong with that particular build. nvm i'm changing to saucy anyways –  MHB Dec 29 '13 at 17:40
2  
In your phone run sudo ifconfig, add the result to your question. –  Braiam Dec 29 '13 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.