Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to enable the user list for lxdm (which is Lubuntu's default login manager). The file /etc/xdg/lubuntu/lxdm/lxdm.conf includes the code shown below but how to configure it? Are white and black for white/blacklisting? Why doesn't disable=0 show the userlist?

[userlist]
disable=0
white=
black=
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I found that this is actually supported in lxdm's config file but not in its default theme. There's a bug report about it.

share|improve this answer
add comment

As of Ubuntu 12.04, the disable=0 in /etc/lxdm/lxdm.conf is working.

The whitelist setting does not seem to work, but the blacklist one does, and the syntax seems to be user names separated by spaces. LXDM appears to include in the user list the first three users it finds whose home directory (as specified in /etc/passwd) are under /home, which is why you will see users like syslog and usbmux listed.

This also means that if you put a user's home directory in a non-standard location (other than /home) then the user name won't be listed. I worked around that by putting in a softlink from /home/[username] to the real location, so I could leave /home/[username] in /etc/passwd and get lxdm to show it in the list.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.