Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 LTS on a new Asus notebook computer (Ubuntu was pre-installed). I tried to download Steam from the software center and received the following error:

Package dependencies cannot be resolved

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

steam-launcher: Depends: curl but it is not going to be installed
            Depends: libc6 (>= 2.15) but 2.15-0ubuntu10.2 is to be installed

Before I tried to download Steam I was successful installing and running minecraft.jar - that is the only other program that I have installed.

I have searched for a solution for this issue on this site but I haven't seen my problem identified exactly and I'm afraid to just keep running other scripts that may cause additional conflicts. Please help! Thanks.

share|improve this question
add comment

1 Answer 1

You should not download Steam from Software Center. Go to

store.steamcommunity.com

and download the version from there. It's a .deb package, meaning it will open in Software Center and install there. It never worked for me to download Steam from Software Center :)

share|improve this answer
    
I tried the direct download and it failed also. I ran a diagnostic from the Terminal as suggested on another post - I'll try to post the results. –  Phillyboy111 Dec 26 '13 at 20:20
    
After the edit I can see what is going on. Try sudo apt-get install curl –  Xylo Dec 26 '13 at 20:51
    
ran sudo apt-get install curl with the following results: Reading package lists... Done Building dependency tree Reading state information... Done Package curl is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'curl' has no installation candidate –  Phillyboy111 Dec 26 '13 at 21:10
    
Can't see the results, pastebin them –  Xylo Dec 26 '13 at 21:10
    
the results wouldn't post because it contained several weblinks and the website wouldn't allow me to post more than two. One error line reads "Err ppa.launchpad.net precise/main i386 Packages 404 Not Found" How do you pastebin? –  Phillyboy111 Dec 26 '13 at 21:13
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.