Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from 10.10 to 11.04 and now my dual monitor support seems broken. When booting, I see the screen duplicated just fine on both my laptop as my external monitor; after logging in, however, the external monitor disables and cannot be enabled.

Hardware:

  • Dell Studio XPS 1640 laptop
  • GFX: Ati Mobility Radion HD4670
  • Extenal monitor: Acer P193W

I get the following error message when applying screen settings:

The selected configruiation for displays could not be applied requested virtual size does not fit available size: requested=(3040,900), minimum=(320,00), maximum=(1600,1600)

lshw output:

  *-display
        description: VGA compatible controller
        product: ATI Technologies Inc
        vendor: ATI Technologies Inc
        physical id: 0
        bus info: pci@0000:01:00.0
        version: 00
        width: 32 bits
        clock: 33MHz
        capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
        configuration: driver=fglrx_pci latency=0
        resources: irq:50 memory:d0000000-dfffffff ioport:2000(size=256) memory:cfef0000-cfefffff memory:cfe00000-cfe1ffff

Screenshots:

Screen settings Error message after clicking apply

share|improve this question

3 Answers 3

You're able to resolve that issue by removing .config/monitors.xml. Steps are: 1.rm ~/.config/monitors.xml in terminal 2.log out and log in 3.call monitors utility and setup your 2 monitor configuration again.

share|improve this answer
    
This has not solved the issue. –  Aron Rotteveel May 11 '11 at 7:31
    
Worked for me ( Ubuntu 11.10 ), but I used the proprietary after the upgrade to oneiric –  vincent Nov 4 '11 at 13:06

You can configure it with ATI Catalyst Control Center (Administraive). It is available from System -> Preferences

share|improve this answer

The error message says that the maximum desktop size is 1600x1600, which is probably big enough to cover the laptop's display (in either landscape or portrait mode) but not the external monitor.

You will probably have to create an /etc/X11/xorg.conf file to set a larger maximum size. A minimal xorg.conf that should achieve this is:

Section "Screen"
    Identifier      "Default Screen"
    Device          "Default Video Device"
    SubSection "Display"
        Virtual         3040 900
    EndSubSection
EndSection

If you've already got an xorg.conf for some reason, try adding the Virtual option to the relevant location.

There shouldn't be much of a downside to setting the Virtual size larger than you need: modern versions of the X server only use as much memory as needed for the current display layout rather than reserving the maximum.

share|improve this answer
    
Sadly, this has not solved my problem. In fact, when adding the virtual parameter, both my laptop and external monitor do active, but are stuck at a max resolution of 1280x800 or so. I have removed the parameter and am now again stuck with only my laptop. Any ideas? –  Aron Rotteveel May 4 '11 at 7:32
    
Looking at your question again, it looks like you might be using the proprietary fglrx driver. Perhaps try switching back to the standard drivers instead. With my Evergreen series Radeon card, the standard drivers work fine with multiple monitors (I don't have an xorg.conf, and it defaults to a 8196x8192 as the maximum size). The standard drivers perform a lot better with this card on 11.04 than they did with 10.10, so it might be worth trying them out again. –  James Henstridge May 4 '11 at 8:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.