Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a asus s56 with preloaded Windows 8 and I've recently upgraded to Windows 8.1.

During the installation of Xubuntu I've selected custom partitioning (something else):

I've formatted in ext4 a partition and I've there the root, I've selected another empty partition for swap and then I've put the xubuntu bootloader in the first, cause I've read that for some reasons it's better to leave boot operations to windows leaving the system MBR intact, and then to insert an entry in the win boot manager.

After installing Xubuntu, I've managed to insert the entry from Windows with EasyBCD: I've choosen Grub2. Restarting the pc the blue screen to select the os appears: If I choose Windows it starts perfectly, if I choose Xubuntu Windows boot manager reports error and doesn't boot Xubuntu.

What can I do?

share|improve this question
    
"I've read that for some reasons it's better to leave boot operations to windows leaving the system MBR intact" - where? why? –  Pavel Dec 26 '13 at 12:13
1  
"The problem [...] is that if you ever have to reinstall Windows or upgrade it, it will wipe the Linux boot loader and install its own (boot loader). Also, some anti-virus programs have been known to install small files in the MBR, so that could be another source of pain, if you have to install an anti-virus program on Windows." linuxbsdos.com/2011/09/21/… –  Frankie Dec 26 '13 at 13:22
    
Looks like mis-advice to me. Reinstall - yes; upgrade - no. Antivirus - never ACTUALLY saw this happen. Anyway, it can be easier to use boot-repair occasionally than to resort to chainloading Linux via Win8 loader, moreover the latter will slow down boot: superuser.com/questions/499617/…. Then, your drive is UEFI, isn't it? AFAIK, EasyBCD doesn't support these. –  Pavel Dec 26 '13 at 14:10
    
Yep is UEFI but so what could I do now to setup a working dualboot? –  Frankie Dec 26 '13 at 17:49

1 Answer 1

up vote 2 down vote accepted

Setting up a working GRUB2 configuration is a more practical solution than chainloading GRUB2, more so on an UEFI drive.

First of all, please disable Secure Boot in BIOS Setup. There are more 'refined' solutions (GRUB UEFI windows boot fail) to marry Secure Boot and Linux, but leave it for now.

Second, run boot-repair (laptop not booting to ubuntu 13.04 after installing windows 8) which should both update and install GRUB2 automatically.

That's all.

share|improve this answer
    
Thanks. It's working. –  Frankie Dec 27 '13 at 1:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.