Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04 is not detecting "only MY wi-fi", its showing all other nearby. MY wifi is working fine on my android, my windows machine (Dual boot on same laptop). I'm goggling this problem since last 3 days.

It was working fine after fresh installation, I upgraded all softwares, media drivers, everything. It was working flawlessly. But next day it refused to connect to "only MY wifi". I followed some steps on Google, but no luck. I reinstalled it, but nothing. Its the third time I'm installing it in last 3 days, but no results.

How can I fix this?

Details :

  1. Dell Inspiron 1464.

  2. WICD Network Manager is installed (I goggled it)

  3. I have wired connectivity but for that I've to stand for hours, that's not a solution.

More details:

========================================

**U:~$ iwconfig
lo        no wireless extensions.
eth2      IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.**

========================================
share|improve this question
    
could you try to following code in a terminal (ctrl + alt + T) 'iwlist wlan0 scan' (assuming your wifi device's name is wlan0) This will give you a list of all wifi networks it can find. Try to find your network in that list. if it isn't we'll try something else –  Arno van der Weijden Dec 26 '13 at 11:56
    
Please edit your question to add details about your wireless card: lspci -nn | grep 0280 –  chili555 Dec 26 '13 at 13:23
    
Take a look at this answer –  user224082 Dec 26 '13 at 13:44
    
change the channel and the SSID name of your router(192.168.1.1) change settings of router->go to wireless. –  Rahul Kathuria Jun 19 at 19:43

3 Answers 3

Make sure your router isn't blocking it. Some routers have safegaurds to prevent new computers from connecting.

Look up your router and find its IP. It's usually like 192.168.1.1 or something like that. It takes you to the routers menu and you can allow your mac address.

To elaborate, open up a browser and type in your routers default IP. It will ask you to login, usually the username is blank and the password is admin but each router is different. You can look up the default username and password easily on google.

Then make sure there are no security settings preventing your computer from connecting.

If all else fails, reset the router. You will have to reconfigure all of the passwords but generally that's a good idea to do anyway. Especially if you do not have a router password (not the password you type in when you connect to the internet, the password and username you create to access your router).

share|improve this answer

There is a bug with some Dell systems where a few routers from some manufactures do not show up (pseudo-randomly).

To make a connection you'll need to act as though it's a hidden network.

Click the wireless symbol in your top bar and select connect to hidden wi-fi network

enter the settings specific for your router and click connect.


If that didn't work you'll have to check whether your laptop can actually see your router.

There are several tools to do this (wireshark's dumpcap, aircrack-ng's airodump-ng etc etc) but I'll use aircrack-ng for this example

install aircrack-ng using the following command in your terminal (ctrl + alt + T)

sudo apt-get install aircrack-ng

next you'll need to start it.

sudo airmon-ng start eth0

This will set your wifi system into monitor mode (mon0)

For layout purposes you'll have to set your Terminal to full screen mode (or just make it a big screen by pressing the 3th button from the top left).

run

sudo airodump-ng mon0

Wait till you see either your essid from your router or your routers mac adress (bssid) pop into the list.

If you do not then try to create some wireless traffic using a secondary wifi computer so it will pop up.

(This is to test if your laptop can actually 'see' your network)

When you see your network pop up note the essid and encryption.

Open a secondary terminal and use the following command

sudo apt-get install wpasupplicant

This will allow you to connect to wpa networks using the terminal

In /etc/wpa_supplicant.conf you put your ssid and password.

gksu gedit /etc/wpa_supplicant.conf

Example:

network={
            ssid="ssid_name"
             psk="password"
}

Assuming your interface is eth0 you can connect to it with...

wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dwext && dhclient eth0

If this didn't work try running

iwlist scan

until your network shows up in the list and then repeat the previous steps

share|improve this answer

I faced exactly the same problem and had similar setup as yours.

I was able to get it working, after logging into the modem and changing its name and password.

I understand this is only possible for home users. But this fixed the issue for me.

share|improve this answer
    
Yes, You're right. I did the same thing and was able to access it again. Sorry for late response. –  Gaurav Aug 2 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.