Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run

nslookup internal.foo.com

I get

Server:         127.0.1.1
Address:        127.0.1.1#53

** server can't find internal.foo.com: NXDOMAIN

For some reason, I am not getting the 172.17.51.3 internal DNS server I added. How do I fix this (via command-line if possible)?

/etc/resolv.conf

nameserver 127.0.1.1
search foo.com

/etc/NetworkManager/system-connections/Ethernet\ connection\ 1

[802-3-ethernet]
duplex=full

[connection]
id=Ethernet connection 1
uuid=4ccfdffe-b3e5-4fb2-906f-28a3e1c7a71b
type=802-3-ethernet
timestamp=1387729723

[ipv6]
method=auto

[ipv4]
method=manual
dns=172.17.51.3;8.8.8.8;
dns-search=foo.com;
address1=172.17.51.9/24,172.17.51.1

SOLUTION

I don't know why NetworkManager seems to be misbehaving, but following the instructions from here seems to work.

Essentially, you appear to have to do something like this:

echo "nameserver 172.17.51.3
nameserver 8.8.8.8
search foo.com" | sudo resolvconf -a eth0.inet
share|improve this question
add comment

1 Answer

I think your nameserver setting isn't correct here. try removing that line and making it 8.8.8.8 (Google DNS which you have set in the NetworkManager). If you look in the query it is using the 127.0.1.1 (Which is a localhost typo of 127.0.0.1)

share|improve this answer
    
actually, I need to look at my internal DNS server 172.17.51.3 first for the ip mapping to internal.foo.com (foo.com is my internal domain) - what is the correct format in that file? –  kfmfe04 Dec 26 '13 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.