Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu 10.04 running on a laptop, connected to a local network via WiFi.

This machine does not respond to pings/ssh connect requests, as if it was firewalled. However, if I ssh from this laptop to another machine on the local network, let's call it B, then, while ssh connection is active, I can ping the laptop from B.

Any suggestions where to look for the problem?

share|improve this question

5 Answers 5

up vote 4 down vote accepted

Could be a network infrastructure issue.

Some routers isolate wireless stations to help prevent randomers getting onto the network and hacking other wireless stations. Some isolate wireless from wired too. Most routers let you configure this behaviour in their admin webmins.

If that's not the case can you expand your question to explain the exact network setup, please.

share|improve this answer
    
You are right, it was WPA-PSK2 in router's settings. As soon I have switched to WPA-PSK issue disappeared. –  Art Sep 20 '10 at 0:40
    
WPA-PSK2 is more secure than WPA-PSK, but it shouldn't have this effect. This seems to be some weird quirk in your router... –  JanC Oct 12 '10 at 10:32

Configuring your system to connect to wireless on boot could solve your problem with ssh.

share|improve this answer
    
System is connected to wireless - I had a live gnome session gunning at the time of testing and was able to ssh to the B machine –  Art Sep 10 '10 at 1:51

Try the following.

  • SSH to some new computer C. On the internet if necessary.

  • Try to connect to A from B.

If this works, the wi-fi router is connecting not incoming packets to A unless there is an outgoing connection keeping from A keeping the wireless link active. I've been seeing this on linksys devices like WRT150N towards the edge of their coverage area or if they are under high load.

share|improve this answer

Is the port open and listening on the machine that is receiving the ssh? Is the ssh program on that machine configured properly?

share|improve this answer

Install gufw from the repos and set a NOBLOCK rule on port 22.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.