Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It used to be ctrl+alt+backspace to kill x server, but for some unknown reason, it was decided to disable that combination and use something else (I think it is right alt + printscreen +k).

So, how to enable ctrl+alt+backspace?

I have seen it can be done with installing dontzap, but I know there is a way to set that combination from system setup.

share|improve this question
add comment

3 Answers 3

up vote 5 down vote accepted

Gnome:

Open the keyboard preferences (Search for keyboard in Dash), go to the Layout tab and press Options. Open Key sequece to kill the X server and toggle Control + Alt + Backspace

enter image description here

KDE:

I don't run KDE so I can't verify it or make a pretty screenshot, but according to the Ubuntu Wiki, you do as follows:

  • Open System Settings

KDE 4.1 - KDE 4.5

  • Select "Regional & Language"

  • Select "Keyboard Layout".

  • Click on "Enable keyboard layouts" (in the Layout tab).

  • Select the "Advanced" tab. Then select "Key sequence to kill the X server" and enable "Control + Alt + Backspace".

KDE 4.6+

  • Select Input Devices under the heading Hardware
  • Select Advanced Tab

  • Click on Configure Keyboard Options

  • Enable "Key sequence to kill the X server" and enable "Control + Alt + Backspace".
share|improve this answer
    
Is that for gnome or KDE? I am using KDE, and I can not find keyboard preferences anywhere –  BЈовић May 3 '11 at 7:40
    
Sorry, I missed it. I found a KDE solution, but I haven't verified it. –  Egil May 3 '11 at 8:52
    
doh it was so simple. And I opened that page, but missed kill x server page. thanks –  BЈовић May 3 '11 at 9:06
    
I tried to disable it but it seems to take no effect: that combo still kills "everything" :( any ideas what might be happening? –  nutty about natty May 5 '13 at 16:34
add comment

Navigate to the keyboard preferences, choose layout and then options. You will find the ctrl+alt+backspace there, just tick it and your good to go

share|improve this answer
    
Where are the keyboard preferences? Do I need to install a package? –  BЈовић May 3 '11 at 7:38
    
You will find this in 'applications' its called "keyboard" –  robin0800 May 3 '11 at 7:48
    
I don't see applications anywhere. Are you using KDE or gnome? –  BЈовић May 3 '11 at 7:50
    
Perhaps you can't do this as this is a gnome setting I think –  robin0800 May 3 '11 at 13:35
    
There is a way, but it was changed. See Egil's answer, as it is correct –  BЈовић May 3 '11 at 20:10
add comment

If you are looking for a solution which is independent of Gnome/KDE/Fluxbox or any Desktop Environment or Window Manager, try the following. This command is part of the X Window System.

From https://wiki.ubuntu.com/X/Config/DontZap#Using_the_command_line

Using the command line

You can type the following command to enable Zapping immediately.

setxkbmap -option terminate:ctrl_alt_bksp

If you're happy with the new behaviour you can add that command to your ~/.xinitrc in order to make the change permanent.

I have provided more information in my answer to 10.10 How can I enable Ctrl+Alt+Backspace?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.