Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have problems during boot with radeon module. black screen appears. if i add "blacklist radeon" to blacklist.conf i can boot normally. but i need vgaswitcheroo which not avaliable without radeon module. Laptop hp pavilion dv6-3125er video Radeon 5650 and intel ubuntu 11.04

May  2 23:59:11 wedens-PC kernel: [   18.392796] [drm] radeon defaulting to kernel modesetting.
May  2 23:59:11 wedens-PC kernel: [   18.392800] [drm] radeon kernel modesetting enabled.
May  2 23:59:11 wedens-PC kernel: [   18.392874] radeon 0000:01:00.0: power state changed by ACPI to D0
May  2 23:59:11 wedens-PC kernel: [   18.392878] radeon 0000:01:00.0: power state changed by ACPI to D0
May  2 23:59:11 wedens-PC kernel: [   18.392883] radeon 0000:01:00.0: enabling device (0000 -> 0003)
May  2 23:59:11 wedens-PC kernel: [   18.392892] radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
May  2 23:59:11 wedens-PC kernel: [   18.392898] radeon 0000:01:00.0: setting latency timer to 64
May  2 23:59:11 wedens-PC kernel: [   18.687536] radeon atpx: version is 1
May  2 23:59:23 wedens-PC kernel: [   30.971462] radeon 0000:01:00.0: GPU softreset 
May  2 23:59:23 wedens-PC kernel: [   30.971464] radeon 0000:01:00.0:   GRBM_STATUS=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   30.971466] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   30.971468] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   30.971470] radeon 0000:01:00.0:   SRBM_STATUS=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   31.131254] radeon 0000:01:00.0: Wait for MC idle timedout !
May  2 23:59:23 wedens-PC kernel: [   31.131256] radeon 0000:01:00.0:   GRBM_SOFT_RESET=0x00007F6B
May  2 23:59:23 wedens-PC kernel: [   31.131360] radeon 0000:01:00.0:   GRBM_STATUS=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   31.131362] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   31.131364] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   31.131365] radeon 0000:01:00.0:   SRBM_STATUS=0xFFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   31.132389] radeon 0000:01:00.0: limiting VRAM
May  2 23:59:23 wedens-PC kernel: [   31.132392] radeon 0000:01:00.0: VRAM: 3584M 0x0000000000000000 - 0x00000000DFFFFFFF (3584M used)
May  2 23:59:23 wedens-PC kernel: [   31.132394] radeon 0000:01:00.0: GTT: 512M 0x00000000E0000000 - 0x00000000FFFFFFFF
May  2 23:59:23 wedens-PC kernel: [   31.132632] [drm] radeon: 3584M of VRAM memory ready
May  2 23:59:23 wedens-PC kernel: [   31.132635] [drm] radeon: 512M of GTT memory ready.
May  2 23:59:23 wedens-PC kernel: [   31.132716] radeon 0000:01:00.0: irq 45 for MSI/MSI-X
May  2 23:59:23 wedens-PC kernel: [   31.132721] radeon 0000:01:00.0: radeon: using MSI.
May  2 23:59:23 wedens-PC kernel: [   31.132733] radeon 0000:01:00.0: IH ring buffer overflow (0xFFFFFFFF, 0, 15)
May  2 23:59:23 wedens-PC kernel: [   31.132759] [drm] radeon: irq initialized.
May  2 23:59:23 wedens-PC kernel: [   31.320480] radeon 0000:01:00.0: Wait for MC idle timedout !
May  2 23:59:24 wedens-PC kernel: [   31.480341] radeon 0000:01:00.0: Wait for MC idle timedout !
May  2 23:59:24 wedens-PC kernel: [   31.484297] radeon 0000:01:00.0: WB enabled
May  2 23:59:24 wedens-PC kernel: [   31.500940] IP: [<ffffffffa0385b16>] evergreen_cp_start+0x56/0xc80 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.501095] Modules linked in: snd_hda_codec_idt snd_hda_intel(+) snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event radeon(+) snd_seq snd_timer hp_wmi snd_seq_device i915 joydev sparse_keymap uvcvideo btusb videodev v4l2_compat_ioctl32 ttm bluetooth rt2860sta(C) snd psmouse serio_raw drm_kms_helper drm crc_ccitt intel_ips video soundcore snd_page_alloc i2c_algo_bit hp_accel lis3lv02d input_polldev coretemp lp parport usbhid hid ahci libahci r8169
May  2 23:59:24 wedens-PC kernel: [   31.501570] RIP: 0010:[<ffffffffa0385b16>]  [<ffffffffa0385b16>] evergreen_cp_start+0x56/0xc80 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502157]  [<ffffffffa0388be0>] evergreen_cp_resume+0x3a0/0x630 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502200]  [<ffffffffa038a8f7>] evergreen_startup+0x157/0x260 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502242]  [<ffffffffa035c8b0>] ? r600_pcie_gart_init+0x60/0x70 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502285]  [<ffffffffa038bc2c>] evergreen_init+0x1ac/0x2d0 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502323]  [<ffffffffa0303a49>] radeon_device_init+0x409/0x490 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502363]  [<ffffffffa0305122>] radeon_driver_load_kms+0xb2/0x1a0 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.502471]  [<ffffffffa039595e>] radeon_pci_probe+0xb2/0xba [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.504059]  [<ffffffffa03db000>] ? radeon_init+0x0/0x1000 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.506708]  [<ffffffffa03db000>] ? radeon_init+0x0/0x1000 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.511972]  [<ffffffffa03db000>] ? radeon_init+0x0/0x1000 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.514474]  [<ffffffffa03db0c4>] radeon_init+0xc4/0x1000 [radeon]
May  2 23:59:24 wedens-PC kernel: [   31.522082] RIP  [<ffffffffa0385b16>] evergreen_cp_start+0x56/0xc80 [radeon]
share|improve this question

4 Answers 4

up vote 2 down vote accepted

I had the same problem. The System would not boot with radeon loaded. I did this:

add blacklist radeon to the end of /etc/modprobe.d/blacklist.conf

add these lines before 'exit 0' in /etc/rc.local

modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Remember to make rc.local executable.

Now the radeon module will be re-loaded, vgaswitcheroo will be reenabled and the ATI card will be turned off. Cooler, quieter

share|improve this answer
    
I should add that deactivating the dedicated gfx card will cause 'atombios stuck in loop..' errors when logging out/shutting down the system. As far as I can see, it does not damage anything, but it delays logout a bit. To make that go away, one must re-activate the dedicated card before logging out –  marto May 6 '11 at 12:41
    
Thank you. This seems to resolve my blank screen issue as well under ubuntu natty on ThinkPad T400 (with Radeon Switchable Graphics). I also set the BIOS under ThinkPad to always use external graphics. –  Antony Sep 4 '11 at 15:13
    
I wish I had a BIOS option. I dont understand why the manufacturers omit so many options –  marto Sep 4 '11 at 15:56

You can boot with the radeon module blacklisted and then load it in rc.local (modprobe radeon). This made my system boot stable.

share|improve this answer

oh as can see, you don't need radeon card, right? you're happy with integrated GPU? if so, simply delete (with synaptics) xorg drivers for radeon (package names are like xorg-driver-ati and xorg-driver-radeon or something similar) the problem is that those drivers somehow won't work properly with default kernel of ubuntu 11.04

i just did that. intel card works just as it used to. vga_switcheroo is in place. everything's good but you can't use radeon card, of course.

share|improve this answer
    
I removed these packages but radeon module still alive –  wedens May 3 '11 at 15:54

check if this post can help:

Getting vga_switcheroo with ATI Mobility Radeon 5650 HD to work

Regards

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.