Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have desktop with 80gb HDD with ubuntu then i added a 2TB but failed to get it mounted tried all links from mounting ntfs on ubuntu search

This is my current config :

Dell:~$ sudo blkid
/dev/sda1: UUID="18692632-7315-41e4-87a6-6849a1632f8f" TYPE="ext4" 
/dev/sda5: UUID="96ce4c1c-79d4-44bd-9cef-7cd754cf7f32" TYPE="swap" 
/dev/sdb1: UUID="3515B80F1E432B77" TYPE="ntfs" 
/dev/sdb2: TYPE="swap" 
/dev/sdb3: UUID="a427c9ca-f16d-42fd-99ee-b114df2bf1b6" SEC_TYPE="ext2" TYPE="ext3" 

This is my fstab

  # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc            /proc           proc    nodev,noexec,nosuid 0       0
    # / was on /dev/sda1 during installation
UUID=18692632-7315-41e4-87a6-6849a1632f8f /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sda5 during installation
    UUID=96ce4c1c-79d4-44bd-9cef-7cd754cf7f32 none            swap    sw              0       0
    #
    /dev/sdb1     /media/Data     ntfs-3g     defaults,auto,users,rw,exec,locale=en_US.utf8   0    0
    #/dev/sdb1     /media/Data     ntfs-3g  uid=1000,auto,users           0  0  

when i run sudo mount -a I get

Dell:~$ sudo mount -a
ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

when i go through userinterface i get

Error mounting: mount exited with exit code 1: helper failed with:
Mount is denied because setuid and setgid root ntfs-3g is insecure with the
external FUSE library. Either remove the setuid/setgid bit from the binary
or rebuild NTFS-3G with integrated FUSE support and make it setuid root.
Please see more information at http://tuxera.com/community/ntfs-3g-faq/#unprivileged
share|improve this question
    
Have you run chkdsk on the NTFS partition? And the boot options I have seen are: defaults,nls=utf8,umask=000,uid=1000,windows_names –  oldfred Dec 25 '13 at 16:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.