Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I seem to be so dumb when it comes to this, well recently my wifi connection was ok. When I did a restart it stopped giving me wireless connections. Even the button on the left that should be lit up when I had wifi connection is no longer turning on.

I tried running lshw -C Network and it gave me this result :

*-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 02
       serial: 00:1e:ec:ce:25:23
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:43 ioport:2000(size=256) memory:51410000-51410fff memory:51400000-5140ffff memory:51420000-5142ffff

How can I fix this?

( Im only using a USB plug in internet thingy for now)

Edit: After checking around, what I see that is weird is when I run the lshw -C network command it doesnt even give me a "Unclaimed" and Network controller result, only the Ethernet cable result.

share|improve this question
    
I'll try to do that tomorrow since I needed to run to work now.. Should that resolve the missing network controller? I was thinking it might have been HW related –  Nar Dec 25 '13 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.