Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu-one doesnt work on my Natty installation. It just fails to launch. Why?

I tried via terminal ubuntuone-launch - aborted, sudo ubuntuone-launch -no output. Why is this?

share|improve this question
    
The question title is pretty vague. –  Thomas Boxley Jun 6 '11 at 5:04
    
@Thomas Should be fixed now. –  WarriorIng64 Aug 8 '11 at 3:42
add comment

1 Answer

Not sure why this is not working, but since upgrading to Ubuntu 11.04 the difficulty is with file syncing. Personally this extends to other applications such as Nautilus and Rhythmbox. I have been searching for possible solutions, but have not found anything that adequately addresses the issue.

UPDATE:

ROOT_MISMATCH in syncdaemon.log - This normally indicates that there may be two Ubuntu One accounts, one in the local cache and another setup in the keyring. This happens if the user installed Ubuntu One with one account and then sets up the computer again with a different account (but all the old Ubuntu One files in ~/.local/share/ubuntuone are still there under the old account). Working around this:

Open Applications->Accessories->Terminal and run:

  u1sdtool -q; killall ubuntuone-login ubuntuone-preferences;
  sudo rm -rf ~/.local/share/ubuntuone
  rm -rf ~/.cache/ubuntuone
  rm -rf ~/.config/ubuntuone
  mv ~/Ubuntu\ One/ ~/Ubuntu\ One_old/ 

Open Applications->Accessories->Passwords and Encryption Keys, go to the Passwords tab, delete the Ubuntu One and Desktopcouch tokens by right-clicking on them and selecting "Delete"
Back in a terminal session, run:

  u1sdtool -q; killall ubuntuone-login; u1sdtool -c 

To get things functioning again, all I had to do was delete my ~/.local/share/ubuntuone directory as indicated above. Hope this helps.

share|improve this answer
    
Still wont work. binoy@binoy-pc:~$ u1sdtool -q; killall ubuntuone-login; u1sdtool -c Aborted ubuntuone-login: no process found Aborted –  Binoy Babu May 6 '11 at 7:20
    
Yeah, the u1sdtool command did nothing for me as well. Instead it was the following command that worked its magic: sudo rm -rf ~/.local/share/ubuntuone. Then for good measure I did rm -rf ~/.cache/ubuntuone and rm -rf ~/.config/ubuntuone. While Ubuntu One was immediately available after the first command, I did not that logging out and then back in seemed to fix the speed issue I was initially experiencing. To date I have not had to do anything else and Ubuntu 11.04 is running flawlessly. –  Kory Wnuk May 7 '11 at 21:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.