Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MacBook Pro notebook with native resolution of 2560x1600 which makes all my desktop details unreadable. I tried increasing DPI, but icons remain small, so I decided to decrease display resolution. I thought that resolution of 1280x800 would work the best, as 4 pixels of the native resolution would become one pixel in the lower resolution. But 1280x800 is not available to set:

$ xrandr -q
Screen 0: minimum 320 x 200, current 2560 x 2538, maximum 32767 x 32767
eDP1 connected 1440x900+0+1638 (normal left inverted right x axis y axis) 286mm x 179mm
   2560x1600      60.0 +
   2048x1536      60.0  
   1920x1440      60.0  
   1856x1392      60.0  
   1792x1344      60.0  
   1920x1200      60.0  
   1920x1080      59.9  
   1600x1200      60.0  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9* 
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
DP1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440      60.0*+
   1280x720       59.9  

So I set resolution of 1440x900 and the desktop is blurry.

I tried setting the native resolution with xrandr --output eDP1 --scale .5x.5 but the effect s not any better.

How to set 1280x800 resolution which is 1/4 size of the native resolution of 2560x1600 to make my screen look better?


It's strange: when I boot to MacOS and try changing retina display resolution to scaled it also offers 1440x900, but the resulting picture is very good.

share|improve this question
Do you have the right graphics card installed? – Jeremy Dec 31 '13 at 6:31
What do you mean by "right"? lspci shows me 00:02.0 VGA compatible controller: Intel Corporation Device 0a2e (rev 09). It's a notebook. – warvariuc Dec 31 '13 at 6:38
I'm not sure. Have you gone to the system settings and selected additional drivers to see what the recommended graphics driver* is (graphics driver, not card, is what I meant previously) – Jeremy Dec 31 '13 at 6:46
Yes, I did. Only Wireless card needed proprietary driver. Anyway, AFAIK "the official Intel drivers for Intel graphics are themselves open-source; thus no proprietary drivers are available" ( – warvariuc Dec 31 '13 at 6:53

Have a look at this.

But in my eyes the result is not better than running 1440x900.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.