Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm guessing it's the NVidia drivers again with the X, that's the thing that gets screwed up after updates 3 or 4 times a year since the new update schedule started.

Tried all the things that fixed it in the past, no help this time, been at it all morning (5 hours so far). What does seem to have some effect is:

The following seems to create run on text, no LF or CR why?

Shows ok in the browser (Firefox)

sudo jockey-text -e xorg:nvidia_304
sudo nvidia-xconfig
sudo nvidia-settings
sudo jockey-text -e xorg:nvidia_304
sudo reboot
sudo startx

Here X comes up without any GUI, blank X screen with background.

That's the best I seem to be able to get. Holding Shift during boot does nothing, it used to show the startup prompts from Grub.

How do we get them back now?

I'm guess it's changed yet again. If I could get to the normal startup screen I have several GUIs loaded and I could try another instead of the default.

Some startup details:

X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-37-generic i686 Ubuntu
Current Operating System: Linux bbc-server 3.2.0-54-generic #82-Ubuntu SMP Tue Sep 10 
20:09:12 UTC 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-54-generic

root=UUID=3e6e688b-41a0-437f-840e-1bd1e33fc483 ro text
Build Date: 16 October 2013  04:45:22PM
xorg-server 2:1.11.4-0ubuntu10.14 (For technical support please see 

http://www.ubuntu.com/support)
Current version of pixman: 0.24.4
...
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec 23 10:32:22 2013
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

At this port X is up, but no GUIs or anything else seem to run. I'm getting there via putty from close by WindowsXP machine. So I opened another terminal to try to get the GUI to do anything:

bcw@bbc-server:~$ sudo lightdm &
[1] 3173
bcw@bbc-server:~$ ps
  PID TTY          TIME CMD
 3067 pts/4    00:00:00 bash
 3174 pts/4    00:00:00 ps

[1]+  Stopped                 sudo lightdm
# so no GUI. *** Merry Christmas *** ;)
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.