Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When Ubuntu 13.10 decides to turn of inactive screen, it runs an animation for 15 seconds long, slowly dimming the screen.

The purpose, I assume, is to give an interim for human intervention - a user reading the screen can touch a key or move the mouse to brighten up the screen, preventing the turn-off.

However it failed the purpose on my Acer Iconic W500, where the keyboard and mouse are both locked up during dimming.

The user sits sadly and helplessly waiting for the screen to dim to complete black, and then can he light it up with a mouse move or keystroke.

How irritating it is to break the user away from reading a complicated article that forced him still for 10 minutes!

It may be a bug, and is perhaps filed somewhere (a quick search didn't reveal one).

Here I am asking only for a workaround, e.g. to turn off the dimming animation. If screensaver decides to turn of the screen, let it turn it off immediately so the user can quickly wake it up, thus being less a nuisance.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Method1:

To get started, open Brightness & Lock utility from Unity Dash search results or from System Settings.

enter image description here

Un-check the box where it says “Dim screen to save power”

enter image description here

Method2:

To get started, open dconf Editor from the dash search results.

enter image description here

In next window, navigate to org -> gnome -> settings-daemon -> plugins -> power. You’ll find the key which says “idle-dim-time”, change its value to 0

enter image description here

If dconf-tools is not installed you can install it via the command

sudo apt-get install dconf-tools
share|improve this answer
1  
Perfect and clear answer. I missed that setting by the first time, because the UI language Spanish is not my native language. –  Zhang Weiwu Jan 7 at 8:08
1  
@ZhangWeiwu Glad to be able to serve you friend –  Ask Jan 7 at 8:15
    
Sorry but this setting has no effect. The screen still dims, taking the same amount of time as before. The setting you suggested is apparently the right one, so I think it is a bug. Fortunately, the old bug of keyboard not responding while dimming, is gone, perhaps with one of the recent package updates, hence I am not bothered with dimming any more. –  Zhang Weiwu Jan 14 at 9:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.