Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a fresh Ubuntu 13.10 and observed the following behavior: My desktop icons are all very tiny and the corresponding file names are not displayed. The following example shows my desktop containing a few LibreOffice documents and a PDF:

Tiny Desktop Icons

Is this behavior expected? And what can I do to get more traditional desktop icons (larger, with text)?

So far I tried not to do anything like unity --reset (which apparently is no longer supported in 13.10 anyways) because the icon problem was already present in the very first boot after the fresh installation, and it would be great if I won't lose all other Unity settings that I have configured in the last few hours.

share|improve this question
    
Try creating a new user, if the problem is still there kill nautilus with nautilus -q. If the problem disappears then you've hit a bug (a weird one), reinstall nautilus then. –  Braiam Dec 26 '13 at 18:48
    
@Braiam: after nautilus -q the icons disappear completely. I created a new users and with this new user the icons indeed look normal! Since it would again take a few days to set-up the new user to my demands, I apparently have to live this bug for now. So far I also could not determine the responsible diff between the various configuration files of these two users. –  bluenote10 Jan 3 at 11:33
    
Mm... if it's only your user there may be a solution. You can try moving all your dotfiles to a temporary location and then restoring them one by one. –  Braiam Jan 3 at 13:49

4 Answers 4

Try this command in terminal:

gsettings set org.gnome.desktop.background show-desktop-icons false
gsettings set org.gnome.desktop.background show-desktop-icons true

Or try changing the icon theme:

gsettings set org.gnome.desktop.interface icon-theme gnome
gsettings set org.gnome.desktop.interface icon-theme ubuntu-mono-light
share|improve this answer
    
Interesting ideas, thank you! Both commands did have the expected effects (switching icons on/off, switching theme) but, unfortunately, the icons still look the same. –  bluenote10 Jan 4 at 15:04
up vote 2 down vote accepted

It turned out, I accidentally made a stupid mistake: One of the first things after installing Ubuntu is to reduce the default size of the list view in nautilus (since imho all default settings are much too large). As a result of my reduce-all-sizes I must have changed the "Default zoom level" under "Icon View Defaults" (under the "View" tab in nautilus' preferences) to the lowest level as well. Since I never ever use the icon view, I never realized that I've made this change and somehow it never occurred to me that this settings affects the look of my desktop icons as well... So in the end, I was able to solve this "issue" simply by setting an icon zoom level of 100% in nautilus.

share|improve this answer

You should be able to right click on the icons and select "Restore Icon's Original Size"

enter image description here

At the moment I'm not sure why your icon's text isn't showing.. I'll have to look into that. When was the last time you restarted and updated?

share|improve this answer
    
This menu option is grayed out on my system, and when I select "Resize Icon..." nothing happens. Since the total age of my system was only a few minutes, the "last" restart/update is not really defined (I enabled "download updates during setup"). However I have restarted a few times since then, and the software updater says "this computer is up to date". –  bluenote10 Dec 26 '13 at 9:27

I encounter the same problem on ubuntu 14.04 LTS.

I solved it by closing the Unity session. Then switch to TTY1 and remove folders like .gnome2, .gconf, .local in home directory.

I don't know which of them was the guilty one, but the clue is to logout from unity before deleting or renaming them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.