Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried running the upgrade from my Ubuntu 13.04 to 13.10 but it failed to upgrade a latex package with the error from [here] (Upgrading from 13.04 to 13.10 stops) and calmed to try to roll back. However the computer clams to be on 13.10.

When I try to run apt-get install I get:

    Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libboost-chrono1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-date-time1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-filesystem1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-graph-parallel1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-graph1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-iostreams1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-locale1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-math1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-mpi1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-program-options1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-python1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-random1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-regex1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-serialization1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-signals1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-system1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-test1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-thread1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-timer1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
 libboost-wave1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed
E: Unmet dependencies. Try using -f.

and when I try apt-get -f install I get the error:

The following extra packages will be installed:
  libboost1.49-dev
Suggested packages:
  libboost1.49-doc xsltproc docbook-xsl fop
The following packages will be upgraded:
  libboost1.49-dev
1 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
40 not fully installed or removed.
Need to get 0 B/9,208 kB of archives.
After this operation, 36.9 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 598837 files and directories currently installed.)
Preparing to replace libboost1.49-dev 1.49.0-3.2ubuntu1 (using .../libboost1.49-dev_1.49.0-4_amd64.deb) ...
Unpacking replacement libboost1.49-dev ...
dpkg: error processing /var/cache/apt/archives/libboost1.49-dev_1.49.0-4_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/bcp', which is also in package libboost1.53-tools-dev 1.53.0-6+exp3ubuntu8
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.49-dev_1.49.0-4_amd64

I considered removing a re-downloading boost but don't what to make my system any weirder and less stable.

Any suggestions on the best way to fix this problem and any other the failed upgrade might have made?

share|improve this question

1 Answer 1

Problem is that the libboost1.49-dev which was installed from an other repository is competing with newly installing libboost1.49-dev from main repository.

So first you need to remove the present libboost1.49-dev.

sudo dpkg --purge libboost1.49-dev

Then clean the apt-cache

sudo apt-get clean

Then run sudo apt-get -f install.

share|improve this answer
    
How would you keep the old version if you wanted have both installed? –  sevenbitbyte Jan 7 at 2:15
    
Did not work dpkg: dependency problems prevent removal of libboost1.49-dev: libboost-dev depends on libboost1.49-dev. dpkg: error processing libboost1.49-dev (--purge): dependency problems - not removing Errors were encountered while processing: libboost1.49-dev –  Silverdev Jan 12 at 6:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.