Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Xubuntu 13.10 on a Compaq Presario V2000 with a BRCM 4318 wireless card. When I turn it on Xubuntu doesn't attempt to search for wireless networks, instead saying the ethernet is offline. I have installed b43-fwcutter and the drivers from the install media. What can I do to make Xubuntu attempt to connect?

share|improve this question
1  
Let's just verify your device. Please edit your question to add the results of these terminal commands: lspci -nn | grep 0280 and also: lsmod | grep -e wl-e b43 –  chili555 Dec 23 '13 at 1:25
    
steve@steve-Presario-V2000-EX657UA-ABA:~$ lspci -nn | grep 0280 05:02.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02) steve@steve-Presario-V2000-EX657UA-ABA:~$ lsmod | grep -e wl-e b43 grep: b43: No such file or directory Also worth noting I have no "enable wifi" option in the network indicator. –  purple112 Dec 23 '13 at 2:30
    
Sorry for my typo. I meant: lsmod | grep -e wl -e b43 –  chili555 Dec 23 '13 at 13:44
    
steve@steve-Presario-V2000-EX657UA-ABA:~$ lsmod | grep -e wl -e b43 wl 4161817 1 lib80211 14040 1 wlcfg80211 401436 1 wl –  purple112 Dec 23 '13 at 18:48

1 Answer 1

up vote 1 down vote accepted

Please get a temporary wired ethernet connect, open a terminal and do:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree

Detach the ethernet, reboot and tell us if it's working.

share|improve this answer
    
Works now. Thanks a ton. –  purple112 Dec 23 '13 at 20:01
    
Awesome! Glad it's working. –  chili555 Dec 23 '13 at 20:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.