Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 3 computers. On the first I have installed MAAS with DHCP and DNS, the other two are ready in the web interface. After I use juju bootstrap one of them is turning blue and the other is still green. When I deploy Juju GUI the two nodes are blue. The Juju GUI is working without a problem.

After that I want to deploy other things with the Juju GUI but they are not deployed, just pending. When there is no ready node the message in the juju status is - Conflict 409. What should I do so that I can deploy other services without adding another and another computer.

share|improve this question
    
I want to know if i can specify to witch machine the service will be deployed in juju GUI something like juju deploy --to 0 juju-gui for example. Thanks –  user226325 Dec 22 '13 at 20:10
1  
Deploying the GUI to machine 0, as you suggest, is expected and recommended; doing so would leave you with a spare machine on which you could run other services. –  fwereade Dec 26 '13 at 21:21
    
Be sure to mark answers as accepted if they answered your question, or at the very least upvote it if it helped. –  hatch Dec 27 '13 at 16:42

1 Answer 1

Well it depends on the service(s) you need to install, and the server specs.

For example you could juju destroy-service juju-gui and juju deploy juju-gui --to 0 on the same node with the bootstrap if the server have enough memory for both. since they don't have any contradicting attributes.

e.g it's not recommended to deploy two charms if the both charms uses apache web service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.