Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I try to log in on the normal log in screen and the screen goes black for a second and then kicks me back to the log in screen. I can log in with a guest session just fine, however. I've tried this with unity, cinnamon and good old fashion gnome, and the same thing happens with all three. I've looked through the log files, but none of them seem to have anything related to this problem. Right now, cinnamon and unity have been completely removed from the system.

share|improve this question

marked as duplicate by Seth, guntbert, Alvar, Eric Carvalho, Avinash Raj Dec 23 '13 at 7:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

This happened to me when I did a new install of nvidia drivers on my laptop. I was still able to login the second go-around though. – Deryck Dec 22 '13 at 17:55

Log in to the guest account. Push Ctrl + Alt + F2

Login with username and password

sudo apt-get install ubuntu-desktop && sudo apt-get install --reinstall lightdm

This happened to me and it fixed when reinstalling Unity and LightDM

share|improve this answer

This is a problem with lightdm. If reinstalling lightdm doesn't help, you may need to install a different display manager. The one I use right now is gdm, but there are others. To fix by using gdm instead of lightdm:

  1. Press Ctrl-Alt-F1(or -F2/3/4/5/6) to get to a command prompt
  2. Log in. Note: your password isn't shown, even as stars
  3. Execute sudo apt-get install gdm
  4. A while after starting the install you'll be asked about which display manager to use. Select gdm
  5. Restart your computer and you should be good to go

If you do this, your login prompt will look different from now on.

share|improve this answer

A long time ago I had this problem - I could login into Guest, but not into my user account. I had a problem with the user account, specially with the file .profile. But removing only the .profile file didn't do the trick for me. I managed to create a new user account. While on the login screen, open the tty1 command-line window by hitting Ctrl+Alt+F1 and run the following command:

sudo useradd -c "newusername" -m -s "/bin/bash" newusername --groups sudo

This command will create a new useraccount for you. Now remove the old user account by running the following command:

sudo userdel oldusername

This will remove your old user account, but not your home folder and you will be able to copy your important files to the newly created user account.

Then remove the old user account home folder by running the following command:

sudo rm -rf /home/oldusername

This is the only way I solved this problem - with creating a new user account and copying my important files from the old user account to the newly created.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.