Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu Gnome 13.10 and after a reboot I got Error:unknown filesystem. Grub rescue. I have tried :

set root=(hd0,6)
set prefix=(hd0,6)/boot/grub
insmod normal

But I get an error at the last one I get this error: Error: no such partition.

I also tried to update grub from a live cd but when I enter: sudo mount /dev/sda5/mnt i get this:

-mount: can't find /dev/sda5/mnt in etc/fstab or /etc/mtab.

Can someone help?

share|improve this question
    
plz upload the gparted screenshot. –  Avinash Raj Dec 22 '13 at 15:37
    
sudo mount /dev/sda5/mnt this was a wrong command,the right one was sudo mount /dev/sda5 /mnt –  Avinash Raj Dec 22 '13 at 15:46

3 Answers 3

First, sudo mount /dev/sda5/mnt won't do anything because /dev/sda* is a block device and doesn't have a folder in it because...it isn't a folder.

This happened to me. Boot to the LiveCD again and use:

cat /proc/partitions

to figure out which drive to choose (hopefully you know what size it was). Then set your grub to the correct root() drive.

To mount it in the LiveCD use

cd ~ && mkdir systmp && sudo mount /dev/*DISK* systmp

Report back with results, of course.

share|improve this answer

Run LiveCD and give us results:

sudo apt-get install parted; sudo parted --list

Download Boot info script ( http://sourceforge.net/projects/bootinfoscript/ ) and paste the result.

You can also give us a screenshot from GParted.

And 2 questions: which partition table are you using and which type is your root partition (for example ext4, ext3, brtfs etc.)?

share|improve this answer

I'm sorry I took so long for me to reply. The problem was that I did not pay enough attention while I was trying to mount the boot partition. My partition is sdab5, not sda. Thanks all for your help!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.