Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All of a sudden I can no longer mount an internal hard drive(/dev/sda aka openSpaceI) via gui or cli.

$ sudo mount /dev/sda /media/openSpaceI

gives this error

mount: wrong fs type, bad option, bad superblock on /dev/sda,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

gives this

$ dmesg | tail
[ 9344.234380] compiz[6098]: segfault at 28 ip 00007f1fa0641335 sp 00007fff0b306700 error 4 in libregex.so[7f1fa063c000+8000]
[ 9987.879043] nautilus[6899]: segfault at 1505b817b60f ip 00007ff6eeefdb8d sp 00007fff09aa6170 error 4 in libgobject-2.0.so.0.2800.6[7ff6eeeca000+4e000]
[10001.231835] compiz[7360]: segfault at 28 ip 00007f38e0cfe335 sp 00007fff3228d380 error 4 in libregex.so[7f38e0cf9000+8000]
[10113.817592] compiz[7429]: segfault at 28 ip 00007f01c11cd335 sp 00007fffac4f4250 error 4 in libregex.so[7f01c11c8000+8000]
[10116.592022] compiz[7651]: segfault at 28 ip 00007f4369548335 sp 00007fffb3b2b030 error 4 in libregex.so[7f4369543000+8000]
[10117.958485] compiz[7666]: segfault at 28 ip 00007f3861d7d335 sp 00007fff268395d0 error 4 in libregex.so[7f3861d78000+8000]
[10366.207793] EXT4-fs (sda): bad geometry: block count 156282966 exceeds size of device (156282701 blocks)
[10855.975855] EXT4-fs (sdb): mounted filesystem with ordered data mode. Opts: (null)
[10863.666747] EXT4-fs (sda): bad geometry: block count 156282966 exceeds size of device (156282701 blocks)
[11125.922998] EXT4-fs (sda): bad geometry: block count 156282966 exceeds size of device (156282701 blocks)

Any ideas?

should I check /etc/fstab for something?

gui error - http://dl.dropbox.com/u/545099/error1.png

share|improve this question
    
add comment

closed as too localized by fossfreedom Jul 2 '12 at 12:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

I found someone with the same problem and who posted an answer here: http://ubuntuforums.org/showpost.php?p=9485779&postcount=7

1st code line looks like having a bug: of=mnt/usb -> of=/mnt/usb

Have a look if that fixes this for you too! I hope is does :)

Also have a look at fdisk and see if the numbers fdisk show are correct for your disk.

Then there is also the option to use 'testdisk' It is an excellent program to analyse disks: http://en.wikipedia.org/wiki/testdisk

share|improve this answer
    
sfdisk -d /dev/sda > PT.txt -----this will backup the entire drive? the partition(whole drive) is 640gb. I don't have a place to back that up right now. –  winchendonsprings May 2 '11 at 21:27
    
testdisk doesn't work on ext4 it seems. I'd like to try the first method you suggest but I'm not sure if I have to backup the whole drive to a file.(640gb) –  winchendonsprings May 3 '11 at 4:07
add comment

Please post the output of ls /dev/sda* to make sure the device is really /dev/sda not maybe e.g. /dev/sda1

If only /dev/sda is printed: what does $sudo fsck /dev/sda say?

share|improve this answer
    
ry@ry-EX58-UD5:/$ ls /dev/sda* /dev/sda ry@ry-EX58-UD5:/$ sudo fsck /dev/sda [sudo] password for ry: fsck from util-linux-ng 2.17.2 ---- does this help? –  winchendonsprings May 2 '11 at 21:20
    
I think it has something to do with my fstab. check it out - dl.dropbox.com/u/545099/fstaberror1.png –  winchendonsprings May 2 '11 at 21:32
add comment

/dev/sda is the entire hard drive. Hard drives are (almost) always partitioned, so you want to mount the partition ( sda1? ).

If you really did format the entire drive without partitions, then it appears that the drive has shrank a bit since you first formatted it.

share|improve this answer
    
How can I readjust the size that the drive says it is? can I fool the machine into reading the disk? –  winchendonsprings Jul 17 '11 at 0:21
add comment

use sudo fdisk -l to list your partitions then mount the partition.

mount /dev/sdxy /media/myMountFolder

replacing sdxy with the appropriate partition, eg. sda1.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.