Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The network manager keeps prompting me for a password, while i'm sure it's correct. Sometimes it connects for a minute. When i used windows 8 at the same place with the same router, i didn't have this connection problems. Apparently someone has filed a bug already (bugs.launchpad.net/ubuntu/+bug/1244408?comments=all).

As stated in the title the model my Belkin wifi adapter is F7D1102 N150/Surf Micro with RTL8188CUS chipset (more information about device) wikidevi.com/wiki/Belkin_F7D1102. I'm using a recently updated Kubuntu 13.10 installation.

When i type lsusb and lsmod in the terminal, i got the following output:

Bus 006 Device 002: ID 050d:1102 Belkin Components F7D1102 N150/Surf Micro Wireless    Adapter v1000 [Realtek RTL8188CUS]

Module                  Size  Used by
rtl8192cu              67723  0 
rtl_usb                18448  1 rtl8192cu
rtlwifi                63229  2 rtl_usb,rtl8192cu
rtl8192c_common        48877  1 rtl8192cu
mac80211              596969  3 rtl_usb,rtlwifi,rtl8192cu
cfg80211              479757  2 mac80211,rtlwifi

dmesg | grep firmware gives:

[   61.782478] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin

I tried several solutions to my connection problems:

Compilation of driver provided by Realtek:

I searched for the RTL8188CUS driver on Realtek's website and tried to compile it myself using the install script. When executing the script, sudo make driverfills my screen with a repeating error: implicit declaration of function?

Installation of Windows drivers on CD with nsdiswrapper

Blacklisted original driver. Windows driver doesn't work.


(Solution) Patched version of original driver (Ubuntu 13.10)

Meanwhile I found at that someone has patched the original rtl8192cu driver link and it works!

share|improve this question

2 Answers 2

This:

rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin

...means that the required firmware was found and loaded; there is no problem there. And this:

Er is geen regel om doel 'Driver

...means that 'make' doesn't work on files with spaces in them, like this:

/home/willem/Bureaublad/Network Driver/RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911

Please rename the folder Network_Driver instead of Network Driver. I suspect it will then compile correctly. However, it is probably not the preferred way to install a different driver. What troubles are you having that made you decide to abandon a working driver and firmware package?

share|improve this answer
    
I didn't have as much connectivity problems in windows 8 with the same router and adapter. Thanks for your fast response. –  wl.vhl Dec 21 '13 at 23:05
up vote 0 down vote accepted

P. Varet has patched the Realtek driver for Ubuntu 13.10: link

Installation (from site)

Ensure you have the necessary prerequisites:

sudo apt-get install linux-headers-generic build-essential dkms

Clone this repository:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Set it up as a DKMS module:

sudo dkms add ./rtl8192cu-fixes

Build and install it:

sudo dkms install 8192cu/1.8

Refresh the module list:

sudo depmod -a

Ensure the native (and broken) kernel driver is blacklisted:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

And reboot. You're done.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.