Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Kubuntu on a Notebook with GeForce Go 6100 graphics card, the tty's were working correctly, but the KDE desktop wouldn't display anything correctly. After installing the nVidia driver using apt-get install nvidia-current as root, the KDE desktop was displayed correctly. But now the TTY's have a very low resolution (the font is about 4x as big as it's supposed to be) and the flashing kubuntu Plymouth-animation was replaced by a text based animation looking like this:

Kubuntu 13.10
.  .  .  .  .

Where the dot's were changing it's color like on Ubuntu (not Kubuntu) bootup.

What happened and how can I fix it?

share|improve this question
    
Try changing the plymouth theme. There is a guide here on changing tty. –  Wilf Dec 21 '13 at 19:24
    
Both don't have any effect. It's the used screen resolution, not the font size. –  the_Seppi Dec 21 '13 at 19:49
    
I guessed that, but I found it useful on a 1024x600 notebook... You could reinstalling` plymouth`, even though the problem is how it displays it... You might just need to configure it to use nvidia card properly... –  Wilf Dec 21 '13 at 19:54
    
And how would I do that if I might ask? –  the_Seppi Dec 21 '13 at 20:03
    
I ran that before and it didn't show any effect –  the_Seppi Dec 21 '13 at 20:06

1 Answer 1

two things

First,

fix grub resolution:

sudo nano /etc/default/grub

Now, locate the line

#GRUB_GFXMODE=640x480 

and change it to this:

GRUB_GFXMODE=1280x800 
GRUB_GFXPAYLOAD_LINUX=keep

Next,

add framebuffer:

echo "echo FRAMEBUFFER=y" | sudo tee /etc/initramfs-tools/conf.d/splash

finally, update grub and initramfs:

sudo update-initramfs -u
sudo update-grub

reboot for the changes to take effect

share|improve this answer
    
source: binarytides.com/ubuntu-fix-nvidia-graphics –  mchid Mar 10 at 8:06
    
I have this same issue but I can't get the fix it work. After reboot the resolution is still 640x480. Also when I run sudo update-initramfs-u to get this error: Warning: Not updating LILO; /etc/lilo.conf not found! –  Michael Lindman Mar 10 at 9:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.