Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a fresh install of Ubuntu 11.04, running Unity, I can't adjust the brightness via Fn+Up/Down. The brightness panel will show, and increase/decrease accordingly, but the actual brightness never changes.

This is an issue I also had on 10.04. I used to fix this by adding this line

Option "RegistryDwords" "EnableBrightnessControl=1"

to my /etc/Xorg/xorg.conf in Section "Device". However it seems this is not working anymore. I also noticed the config file is much smaller that what I remember. Here is the whole file:

Section "Device"
Identifier      "Default Device"
    Option  "NoLogo"        "True"
    Option  "RegistryDwords"        "EnableBrightnessControl=1" 

Should I use this line somewhere else ? or is there something else to fix ?

For reference, here is the original issue on 10.04:

share|improve this question
Did you solve the problem? I've got the same on my 3500... – Mateusz May 14 '11 at 16:08
No, not solved. I'll post the answer if I find it. – PowerKiKi May 15 '11 at 11:06
up vote 4 down vote accepted

i have same problem on dell vostro 3500 and solution from this question helped me to fix brightness bug: Screen brightness not changing on Acer 5742 notebook.

The complete solution is:

  1. edit /etc/Xorg/xorg.conf to add the following line in Section "Device":

    Option "RegistryDwords" "EnableBrightnessControl=1"
  2. edit /etc/default/grub to change the line into:

  3. run the command:

    sudo update-grub
  4. reboot

share|improve this answer
It worked for me, however I had to re-add the line in my xorg.conf as described in the OP. Thank to everybody involved in this answer ;-) – PowerKiKi May 18 '11 at 21:39
It's still working for Ubuntu 11.10 – PowerKiKi Nov 15 '11 at 1:06
It also works for Ubuntu 12.04 (Dell Inspiron 17R 7720; used "acpi_osi=" instead though but still worked) – Patelify Dec 27 '12 at 4:12
Still working on 13.04 with one difference. There is no xorg.conf by default. To create one stop Xorg and run from root following commands: X -configure and then cp /root/ /etc/X11/xorg.conf – Novarg Jun 16 '13 at 13:03

I believe you need to install Nvidia blacklight driver (nvidia-bl-dkms). The package itself has been developed for MacBooks, but they use same Nvidia model – G310M.

share|improve this answer
Sounds like a good idea, but unfortunately it didn't help at all, even after a reboot. Another guy has similar result: – PowerKiKi May 15 '11 at 11:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.