Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Please don't mark it duplicate. I have been through the rest of the posts and suggestions!

I am trying to dual boot Windows 7 with Ubuntu or Kali Linux but i am unable to do so.

I have backed up all my data to an external hard drive. So it is safe to work with partitioning.

I have a 500 GB hard drive and installed windows 7 onto a 150GB partition created with windows 7 installer partitioning tool.

I created Kali Linux bootable USB but when i proceed to the manual partitioning tool in the installer, it doesn't detect the Windows partition. It says the 500 GB space is free (unallocated).

I booted into the live kali linux form usb and tried gparted. It gives me the following error.

/dev/sda contains GPT signatures, indicating that it has a GPT table.  However,
it does not have a valid fake msdos partition table, as it should.  Perhaps it
was corrupted -- possibly by a program that doesn't understand GPT partition
tables.  Or perhaps you deleted the GPT table, and are now using an msdos 
partition table.  Is this a GPT partition table?

I tried the fdisk and its output is given below.

root@kali:~# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes 255 heads, 63 sectors/track, 60801
cylinders, total 976773168 sectors 
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xf17f14b8

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   115345407    57569280    6  FAT16
/dev/sda3       115345408   430327807   157491200    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 7747 MB, 7747397632 bytes
255 heads, 63 sectors/track, 941 cylinders, total 15131636 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000b19d6

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63    15131635     7565786+   c  W95 FAT32 (LBA)

How should i fix this?

share|improve this question

marked as duplicate by Rod Smith, guntbert, Eric Carvalho, Alvar, Avinash Raj Dec 22 '13 at 7:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
i asked the same question on superuser but got no support. –  Majid Dec 21 '13 at 10:09
    
Don't use fdisk with GPT, used parted instead. –  guntbert Dec 21 '13 at 20:32

1 Answer 1

I didn't use fixparts. While booted from ubuntu, i decided to lose all my data on hard drive since i had that backed up to an external hard drive. So i repartitioned the drive with gparted. There were stray GPT entries. Created a ntfs partition for windows, ext4 for ubuntu and a linux swap. Installed windows and then ubuntu. Solved!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.