Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use USB output for sound. Since updating to 11.04 I have witnessed the following problem, which many other users, as described in Bug #761312, also experience:

For a while I can watch a flash video or listen to music from Banshee perfectly fine. In a seemingly random moment the sound starts getting jittery - i.e. a hissing background noise / white noise appears - getting constantly worse, until being totally unusable. When the sound goes bad, it does so across both Flash and Banshee. As many others have described it does not matter was player you are using and it is not gstreamer specific either, as it also occurs with xine etc.

I have tried killing the pulseaudio process to no help. I pause whatever is playing and after some time the sound starts working again.

Strangely, when the problem occurs and I set my sound output to mono, the problem goes away for a short time, but then starts to jitter again fairly quickly.

I have tried Google with no luck and I have not changed any sound settings since upgrading from 10.10

The problem in still present in Oneiric.

share|improve this question

closed as too localized by jrg Feb 24 '12 at 22:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 24 '12 at 22:43

2 Answers 2

I had this exact same problem. I have not figured out exactly WHY it happens, but I did note some events that seemed to precede the issue: A) I left my computer on for an extended period of time, B) I ran a system update while Banshee was open or C) I had flash videos (Hulu, YouTube) in a FF tab that had not been active for awhile (ie, I had a video loaded but it was paused or something).

All of these things appeared to be precursors to the sound getting jittery, although none of them may be the actual cause. Maybe someone else will have insight.

I solved this by running "ps -A | grep 'audio'" in a terminal. It returned:

891  ?        00:00:00 hd-audio0
2136 ?        00:23:29 pulseaudio

I killed hd-audio0 and pulseaudio, then killed Banshee's process. I re-launched Banshee and the sound issue seems to have been resolved.

share|improve this answer
    
Every restart just helps for a while, I have to do it again. –  kristjan Jul 4 '11 at 7:01

I am not sure but try to set your usb device as default sound device. Go to Sound menu [from system tray] > Hardware select hardware, profile to: digital stereo duplex or digital stereo output + analogue. Test your sound. Go to Output tab and select your usb device as default. Hope this will help.

share|improve this answer
    
Well, I already have USB as a default output device, since the sound is working. Sometimes, it just does not work properly. It seems other people are having a similar issue as well: bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/775076 –  kristjan Jul 4 '11 at 7:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.