Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running XBMCBuntu 12.10 on an HTPC with the server hostname 'SCREEN', and trying to setup Samba to allow access to a share called 'Movies' by mapping username/password credentials to a unix user account (I don't want to allow guest access.) The name of the user is 'user'. I am able to log into the samba server from my Windows 7 PC's via the UNC path \\192.168.1.103 or via \\SCREEN. I am prompted for the the username and password, and when I enter them, it accepts them. (I set this up via smbusers, mapping the password via passwd.) I know the security settings are correct because if I use incorrect credentials at the prompt, it gives me an error.

The problem is that I can't see the shared folder that I have defined in smb.conf. I.e. I just get a blank window in Explorer with no error. And if I try browsing directly to the share via \\192.168.1.103\Movies, it just says "Windows cannot access \192.168.1.103\Movies - Error code: 0x80070035 The network path was not found.". I have a few other observations that might be relevant:

  • The config file in /etc/samba/smb.conf is blank. The one that seems to be applicable is in /usr/share/samba/smb.conf.
  • sudo testparm -s smb.conf > smb.conf.good fails with -bash: smb.conf.good: Permission denied
  • The /var/log/samba/log.smbd doesn't seem to contain any errors:

[2013/12/20 21:35:28,  0] smbd/server.c:1053(main)
  smbd version 3.6.6 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2011
[2013/12/20 21:35:28.852983,  0] smbd/server.c:1109(main)
  standard input is not a socket, assuming -D option

My smb.conf:


[global]
   workgroup = WORKGROUP
   server string = %h server (Samba, Ubuntu)
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = user
   username map = /usr/share/samba/smbusers
   usershare prefix deny list = /
   encrypt passwords = no
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
[Movies]
   path=/home/user/Movies
   browseable = yes
   guest ok = no
   read only = no
   create mask = 0777
   directory mask = 0777
   writeable = yes
   valid users = user
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The problem is that the config file /etc/samba/smb.conf was blank. I overwrote it with the config file from /usr/share/samba/smb.conf and then restarted Samba:

sudo cp /usr/share/samba/smb.conf /etc/samba/smb.conf

Now I have a different problem (authentication), but I am going to troubleshoot that one separately, and possibly post a new question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.