Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After trying to format my 1tb HDD for windows from my SSD with ubuntu, I got the "no such device Grub rescue" Error upon trying to start ubuntu. I booted from a live CD and used the terminal to reinstall grub with boot repair, but I was told that the standard was 32bit and I needed 64bit. I made a 64bit Boot Repair CD and when I tried to boot from that I got the same error as my SSD. I also tried the "How to Repair, Restore, or Reinstall Grub 2 with a Ubuntu Live CD or USB" guide which tells me to mount the partition linux is on. After trying sudo chroot /mnt I got the error "chroot: failed to run command ‘/bin/bash’: Exec format error" Since this is a new build I'm to the point where I'm just going to erase and reinstall Ubuntu.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.