Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I haven't found similar posts anywhere so I would be grateful for any help.

I've seen a couple of machines run Ubuntu using legacy mode and Windows using UEFI boot. This requires a switch of boot options in BIOS, which I'm OK with. So the behavior that I'm looking for is exactly this, in legacy mode, boot ubuntu, in UEFI mode, boot windows provided I make the BIOS switch at startup.

However, after a series of installations and running boot-repair, which i've explained below, I can only boot ubuntu in the legacy mode and when I switch to UEFI mode, I go to grub rescue because it says "no file found". Now I can't boot into windows in any mode!

This is the sequence that caused this. -Windows 8 x64 preinstalled -Tried installing ubuntu in uefi, ran boot repair and this seemed to delete everything. -Reinstalled ubuntu in legacy mode, ran boot repair which doesn't work in the legacy mode

Now only ubuntu in legacy mode works. There is no grub menu at all in the uefi mode.

Here is the link to my boot info http://paste.ubuntu.com/6608333/

How can I add a boot menu in the uefi mode while still having my ubuntu running in legacy mode.

share|improve this question
    
I have ran across the problem and never found an easy solution. You have to boot your windows recovery disk and if you can not repair from the recovery disk, re-install windows. –  bodhi.zazen Dec 21 '13 at 0:02
    
Will this retain my legacy installed ubuntu? –  r11 Dec 21 '13 at 1:10
    
Yes, but it will not boot with the windows boot loader unless you install Ubuntu with uefi enabled. –  bodhi.zazen Dec 21 '13 at 1:32
add comment

1 Answer 1

up vote 1 down vote accepted

Boot Repair has renamed the Windows boot loader file and put a copy of GRUB in its place. The Windows boot loader file should be EFI/Microsoft/Boot/bootmgfw.efi on the EFI System Partition (ESP), but Boot Repair has renamed it to bkpbootmgfw.efi and put GRUB in its place. You need to undo this damage. There's an option to do this on the Boot Repair Advanced menu page, or you can do it manually by renaming the file.

Incidentally, you may want to check out my rEFInd boot manager. It starts up in EFI mode and can pass control to the Windows EFI boot loader. It can also pass control to a BIOS-mode boot loader such as GRUB, although you'll need to uncomment the scanfor line in refind.conf and ensure that hdbios is among the options. rEFInd can also boot Linux in EFI mode. It's not clear why you want to do a BIOS-mode boot of Linux, but IMHO it's usually better to do an EFI-mode boot unless you've got some specific problem with that (like a video card that's not working well in EFI mode).

share|improve this answer
    
Thanks Rod. This worked like a gem. I used boot repair to undo the EFI rename option. I wanted to retain BIOS boot of linux only because I have a lot of ongoing work and didn't want things to get messed up. This was the way I had originally installed and wanted to stick to it. –  r11 Jan 22 at 23:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.