Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I connect using NX (NoMachine's; not FreeNX), the launcher stays there, on top of open windows. I haven't been able to close it at all.

Locally (with full unity instead of unity-2d, that is), it works without problems.

Any ideas?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Issuing the following commands should solve your problem.

gconftool-2 --type=int --set /desktop/unity-2d/launcher/hide_mode 2
gconftool-2 --type=bool --set /desktop/unity-2d/launcher/use_strut false

share|improve this answer
    
It works! Thanks for digging this question! –  Diego Mijelshon Jul 27 '11 at 12:29
add comment

Note this is not NX-specific, so it may or may not solve your problem. But it's worth a shot.

First, do you have it set to auto-hide or dodge windows? Double check your configuration options.

There's a bug where the launcher occasionally sticks open, even with these options. In my case, some windows management actions in a java application (NetBeans) triggers the bug, but I've also heard of some people having the same issue with Google Chrome.

To reset the Launcher's hiding behavior, take a file icon from your desktop or any nautilus folder, drag it over the launcher until it dims, then drag it back off. For whatever reason, this seems to get it hiding again.

share|improve this answer
    
I've double-checked config settings (got a nice unity-2d UI configurator) and I tried the icon thing. I'm still unable to make it work :-( –  Diego Mijelshon May 12 '11 at 0:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.