Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Upgraded ubuntu to 13.10, I am using a Realtek wifi card on a minipc. The wifi connection goes slower than it should: speedtest gives me a 15mB/s download when on my phone it gets around 30 and the connection keeps dropping (signal level goes from 4 to 0 and I am asked wifi passw again and again).

This is the output of

lsmod | grep rtl

rtl8192ce             137725  0 
rtlwifi               110108  1 rtl8192ce
mac80211              596969  2 rtlwifi,rtl8192ce
cfg80211              479757  2 mac80211,rtlwifi

If i run iwconfig I get

wlan0     IEEE 802.11bgn  ESSID:"MYNETWORK"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: A4:B1:E9:6C:B0:B3   
          Bit Rate=65 Mb/s   Tx-Power=33 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=46/70  Signal level=-64 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4   Missed beacon:0

Any ideas?

share|improve this question
    
Can you run uname -r to give us the kernel version. Do you have ethernet access to download packages? And are you on a 64 or 32 bit install? –  Julian Stirling Dec 20 '13 at 12:00
    
3.11.0-14-generic I am on a 64 bit version –  Stefano Vergani Dec 20 '13 at 12:02

2 Answers 2

There have been a lot of wifi problems with 13.10 with Kernel 3.11. This is often (not always) fixed by upgrading to 3.12. If you have wired internet download the new kernel:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200-generic_3.12.0-031200.201311031935_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200_3.12.0-031200.201311031935_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-image-3.12.0-031200-generic_3.12.0-031200.201311031935_amd64.deb

Then run:

sudo dpkg -i linux-headers-3.12.0-*.deb linux-image-3.12.0-*.deb
sudo update-grub
sudo reboot

This should install the new kernel and then reboot.

share|improve this answer
    
user1703577 commented that they have tried this and it did not work. (In future please use comment rather than editing post) –  Julian Stirling Dec 20 '13 at 14:34
    
Sorry, I didn't mean to edit the post, I did it by mistake –  Stefano Vergani Dec 20 '13 at 14:39
    
No problem, sorry my idea didn't help. –  Julian Stirling Dec 20 '13 at 15:00

Type

test(hd0) badram(hd0) sleep 10 set net_default_server=(hd0),

and

set pxe_default_Server=hd0

and restart Ubuntu it should work fine.

share|improve this answer
    
So I should type unetbootin boot usb on my terminal? –  Stefano Vergani Dec 20 '13 at 15:53
    
Michaele, When I typed your suggestion I received the message: bash: syntax error near unexpected token `hd0' Any other suggestion? –  user227385 Jan 10 at 22:32
    
Can you please say where to type these commands? –  RolandiXor Jan 11 at 4:36
    
Typed the first line and got this error bash: syntax error near unexpected token 'hd0' –  Stefano Vergani Jan 13 at 15:45
    
Hi. its proplealy other then Hd0 –  Michael Jan 14 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.