Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I seem to be missing something boost related.

Dogecoin gives the requirements as:

qt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev libssl-dev libdb++-dev libminiupnpc-dev

https://github.com/dogecoin/dogecoin/blob/master/doc/readme-qt.rst

compile error:

s/db/build_unix -Ic:/deps/ssl/include -Ibuild -Ibuild -o build/net.o src/net.cpp
src/main.cpp:17:53: fatal error: boost/random/uniform_int_distribution.hpp: No such file or directory
compilation terminated.
make: *** [build/main.o] Error 1
make: *** Waiting for unfinished jobs....
thufir@dur:~/dogecoin$ 
thufir@dur:~/dogecoin$ apt-cache search libboost1.53-all-dev
thufir@dur:~/dogecoin$ 
thufir@dur:~/dogecoin$ sudo apt-get install libboost-all-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libboost-all-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
thufir@dur:~/dogecoin$ 

see also:

http://b.agilob.net/such-address-many-dig-on-linux-wow/

share|improve this question

1 Answer 1

Try

sudo apt-get install libboost1.48-all-dev

Then

make -j2 -f makefile.unix USE_UPNP=-

if you're making the daemon version. The USE_UPNP=- nullifies the need to install miniupnpc. As far as libqrencode, that is option as well.

share|improve this answer
    
ok, that seems to have done the trick :) it's taking a very long time to synch, but there's a GUI, so, as far as I can tell, the compile completed. –  Thufir Dec 20 '13 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.